Problem splitting topic while filtering by user


(Andrew Waugh) #1

I just tried to split a 1300 post topic, splitting about 200 posts to a new topic.

I used filter by user, then selected “this post and replies” on those posts.

I could only move to an existing topic (created one in another tab).
First try it gave a generic error message.
I closed the other tab, then I could move the selected posts.

BUT…
It moved much more than just the posts I’d selected (only left 2 posts in the original).
It closed the original topic.

Is this a bug, or PBKS?


(David Taylor) #2

Did you select the OP? If so, you cannot move that to a new topic.

Difficult to know what’s going on here without the exact error message. Anything in the logs?

I just tried, and it looks like “select this post and replies” does not respect any filtering. “Select +below” does respect filtering. This sounds like a bug (albeit a very rare edge-case).

This is to be expected if you moved the OP.


(Andrew Waugh) #3

No, as a matter of fact the first post I selected was about half way through… only the top 2 posts were left in the original.

I may try it again.

I’d rather it be a bug than PBKS.

I didn’t select the OP’s initial post, and he hasn’t replied to any of the user’s posts I’m trying to move (but he may have replied to a reply).

Here’s the topic:

I was trying to split posts by vlad11 from 1363 on.


(Jeff Atwood) #4

This is kind of an unsupported mode you are in at that point.

Also, 200 posts might have timed out on the back end, as moving is an (unfortunately) expensive operation.