Problem when i install plugins


(DjCyry) #1

When i want to install a plugin , i get this error :

    FAILED
--------------------
RuntimeError: awk -F\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print "Authorized SSH keys for this container:"; } NF>=2 {print $NF;} failed with return #<Process::Status: pid 1541 exit 2>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "awk -F\\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print \"Authorized SSH keys for this container:\"; } NF>=2 {print $NF;}"
e7574f8884717c7d5455a1265b9883d
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(Sam Saffron) #2

Need more logs please


(DjCyry) #3

@sam , doesnt show more info , only this :

FAILED

RuntimeError: awk -F# ‘{print $1;}’ ~/.ssh/authorized_keys | awk 'BEGIN { print “Authorized SSH keys for this container:”; } NF>=2 {print $NF;} failed with return #<Process::Status: pid 1598 exit 2>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn’
exec failed with the params "awk -F\# ‘{print $1;}’ ~/.ssh/authorized_keys | awk 'BEGIN { print “Authorized SSH keys for this container:”; } NF>=2 {print $NF;}"
ea5720343c2443f428e734c9867413ae95d3fe13079dc43147fe56726be40708
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one
root@vps324:/var/discourse#

ssh : http://www.tupics.net/image/hUh


(Sam Saffron) #4

its in the screenshot, just unterminated string, just nuke your custom commands from app.yml you don’t need them


(DjCyry) #5

Nuke custom commands ? what do you mean @sam ?
i have use this tutorial for install plugins :

Access your server (use Putty on Windows)
Type cd /var/discourse
Type nano containers/app.yml
4.) Arrow down until you see this:

techAPJ:
hooks: after_code: - exec: cd: $home/plugins cmd: - mkdir -p plugins - git clone GitHub - discourse/docker_manager: plugin for use with discourse docker image
5.) Paste “- git clone GitHub - discourse/discourse-spoiler-alert: A plugin for discourse to hide spoilers behind the spoiler-alert jQuery plugin” beneath that so that all together it looks like this:

techAPJ:
hooks:
after_code:

6.) control + O (to save app.yml), hit enter

8.) control + X (to exit app.yml), then hit enter

9.) git pull (this updates stuff)

10.) ./launcher rebuild app (restarts Discourse and includes the plugin)


(DjCyry) #6

I have try to install only the “solved” plugin and i get the same error :

FAILED
--------------------
RuntimeError: awk -F\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print "Authorized SSH keys for this container:"; } NF>=2 {print $NF;} failed with return #<Process::Status: pid 1592 exit 2>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "awk -F\\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print \"Authorized SSH keys for this container:\"; } NF>=2 {print $NF;}"
c171a61b79468be78da05f8a09eaeb025e93e9e18f6fa00ccf70f6dc0fafd2a2
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one
root@vps324:/var/discourse#

(DjCyry) #7

Anyone can help me ? thanks :stuck_out_tongue:


(DjCyry) #8

Anyone can help me ?


(Zack Piper) #9

Could you give us your app.yml with passwords ommited, thanks.


(DjCyry) #10

Sure , here you have , and thanks a lot :slight_smile:

app.yml (4.0 KB)


(Zack Piper) #11

Ran a diff on the file you gave me and the file from https://raw.githubusercontent.com/discourse/discourse_docker/master/samples/standalone.yml (default file)

You need to add a single quote: ' to the end of the line where it says “awk” :smiley:


(DjCyry) #12

OMG …ok , thanks , i will try again now to reinstall plugins .


(Zack Piper) #13

Haha, you’re welcome. Don’t worry, we all make this sort of mistake. :smiley: