Problems after updating docker


(Luis Rock) #1

Hi. Newbie here. I have Discourse installed and running on a digital ocean droplet. Today I went for an upgrade. I saw at the upgrade page that the only button enabled was the one to upgrade Docker. I thought: “well, maybe I need to upgrade docker first in order to be able to upgrade Discourse itself after”.

So I clicked the button and Docker was succesfuly upgraded. Then I returned to the Discourse upgrade page, just to see the following message:

<html><head></head><body>
<h2>You are running an old version of the Discourse image.</h2>
<p>
Upgrades via the web UI are disabled until you run the latest image.
</p>
<p>
To do so log in to your server using SSH and run:
</p>

<pre>
cd /var/discourse
git pull
./launcher rebuild app
</pre>
<p>
<a href='https://meta.discourse.org/t/how-do-i-update-my-docker-image-to-latest/23325'>More info on our support site</a>
</p>
</body>
</html>

Well, I’ve SSH the server, but it is asking me to provide informations for install Discourse, WHICH IS ALREADY INSTALLED AND RUNNING!

My knowledge stops here. Can anyone help me?


(David Taylor) #2

Did you use the Digital Ocean ‘one-click’ version of Discourse. If so, I believe you just need to hit Ctrl c once you’ve SSHed into the server. That should take you out of the setup thing and back to a normal command line.


(Luis Rock) #3

Thanks, David. That worked, but everytime a SSH the server, the same message appears…

Is there a way to delete the Discourse image? I don´t want the server prompting me all the time to install Discourse, when I already have it up and running. And the image must be big…it should be removed.

Any hint?


(David Taylor) #4

You could try this:


(Luis Rock) #5

Thanks again, David. Worked like a charm.