# Problemi di avvio di discourse in vmware

**URL:** https://meta.discourse.org/t/problems-bootstrapping-discourse-in-vmware/208285
**Category:** Support
**Created:** [4 Novembre 2021, 7:09pm UTC](https://meta.discourse.org/t/problems-bootstrapping-discourse-in-vmware/208285 "2021-11-04T19:09:23Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Wurzelseppi](https://avatars.discourse-cdn.com/v4/letter/w/eada6e/32.png) [@Wurzelseppi](https://meta.discourse.org/u/Wurzelseppi)
#### Post date: [4 Novembre 2021, 7:09pm UTC](https://meta.discourse.org/t/problems-bootstrapping-discourse-in-vmware/208285/1 "2021-11-04T19:09:23Z")

</div>

Ciao a tutti,

Voglio installare Discourse localmente su una VM VMware con Ubuntu 21.04, ma ricevo questo errore:

> ./launcher bootstrap app  
> cd /pups && git pull && git checkout v1.0.3 && /pups/bin/pups --stdin  
> fatal: unable to access ‘[GitHub - discourse/pups: Simple yaml based bootstrapper for Linux machines · GitHub](https://github.com/discourse/pups.git/)’: Could not resolve host: [github.com](http://github.com)  
> e0146dd79cd1704e68b8c6aab0168f269af67c8eac4880a7c2ed4276e78031f2  
> \*\* FAILED TO BOOTSTRAP \*\* scorri verso l’alto e cerca i messaggi di errore precedenti, potrebbero essercene più di uno.  
> ./discourse-doctor potrebbe aiutare a diagnosticare il problema.

Tuttavia, quando provo a clonarlo in /tmp, funziona:

> /tmp# git clone [GitHub - discourse/pups: Simple yaml based bootstrapper for Linux machines · GitHub](https://github.com/discourse/pups.git/)  
> Cloning into ‘pups’…  
> remote: Enumerating objects: 477, done.  
> remote: Counting objects: 100% (136/136), done.  
> remote: Compressing objects: 100% (97/97), done.  
> remote: Total 477 (delta 60), reused 94 (delta 33), pack-reused 341  
> Receiving objects: 100% (477/477), 83.41 KiB | 1.63 MiB/s, done.  
> Resolving deltas: 100% (233/233), done.

Anche un nslookup funziona (che sorpresa, eh 🙂 ):

> nslookup [github.com](http://github.com)  
> Server: 127.0.0.53  
> Address: 127.0.0.53#53
> 
> Non-authoritative answer:  
> Name: [github.com](http://github.com)  
> Address: 140.82.121.4

Qualche idea?

Grazie mille, ragazzi!

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [4 Novembre 2021, 11:06pm UTC](https://meta.discourse.org/t/problems-bootstrapping-discourse-in-vmware/208285/2 "2021-11-04T23:06:57Z")

</div>

Sembra che la tua installazione di Docker abbia problemi di DNS.

---

<div class="post-metadata">

### Author: ![Wurzelseppi](https://avatars.discourse-cdn.com/v4/letter/w/eada6e/32.png) [@Wurzelseppi](https://meta.discourse.org/u/Wurzelseppi)
#### Post date: [7 Novembre 2021, 11:15am UTC](https://meta.discourse.org/t/problems-bootstrapping-discourse-in-vmware/208285/3 "2021-11-07T11:15:42Z")

</div>

Hmmmm, su un’istanza cloud ha funzionato perfettamente… Chiudo qui.
