Problems with nginx ports

Hi !
I have several problems. The first is that I tried to change the default port of my server on 443, who was not opened. It didn’t work, I had this result :

When I put back the default opened port in 80, I had the same result. How to reconnect the port with my discourse ? I tried to reboot my server, re-settings my discourse, but it doesn’t work…

Someone has an answer to my questions ?
Thanks :slight_smile:

Discourse does not support running on non-default ports.

But 80 and 443 are default ports, no? :thinking:

I am not sure I understand what you are asking, what are you trying to do? Discourse, as installed, runs on the default ports with zero configuration.

Are you trying to follow discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub?

You need not to have any other web servers running. It appears that you have Nginx running already. You need to un-install or disable it.

1 Like

Yes, but my server was not configured with the port 443 (only the 22 (SSH) and 80 (HTTP) ports were open. I installed my discourse, with no problem, except that the 443 (HTTPS) port was not available. So I couldn’t use it in the Discourse app, by exemple.
To have the full accessibility and more security, I tried to open my port 443 in the server, and I moved the default port of my ubuntu server from 80 to 443, to have the https (I find it quite logic).
But when I went to the server port 443, this message was shown, in the place of my Discourse. I decided to change the settings of the discourse to check if let’s encypt could access to my server to run a certificate. The settings said me that the server was not available in the port 443 , but that my port 80 was still open (message with good DNS settings, so).

So I tried to edit the default nginx port to 80 (the previous settings, so), to get again my discourse.
But I have always the same Nginx page… So how could I get again my Discourse ?

So if I uninstall nginx, it will be appear again?

Good, Thanks @pfaffman !
But now, how can I open the port 443 on my server if I can’t do it with nginx?

Run discourse-setup and provide an address for let’s encrypt.

It doesn’t work…

I think your problem is that you’ve set a port number which is not allowed on a production Discourse instance. That’s only for local development of Discourse by programmers.

You need to remove the port number override and accept the default. Searching here will probably provide your answer.

1 Like

My guess, especially since port 80 works, is that Your cloud provider has the port blocked. Did you Google as suggested?

Who is your provider of your server?