Problems with SSL certificate integration


(Luisfpinto) #1

Hello, I’ve followed the instructions to implements the ssl certificate but when I do

./launch rebuild app

I get the following error:

run-parts: executing /etc/runit/1.d/copy-env
run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
Started runsvdir, PID is 22
sh: echo: I/O error
ok: run: redis: (pid 30) 0s
ok: run: postgres: (pid 31) 0s
30:M 06 May 14:52:13.224 * Redis 3.0.6 (00000000/0) 64 bit, standalone mode, port 6379, pid 30 ready to start.
30:M 06 May 14:52:13.225 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
30:M 06 May 14:52:13.226 # Server started, Redis version 3.0.6
30:M 06 May 14:52:13.227 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
30:M 06 May 14:52:13.227 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003 ]
rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try http://www.rsyslog.com/e/2039 ]
30:M 06 May 14:52:13.275 * DB loaded from disk: 0.048 seconds
30:M 06 May 14:52:13.275 * The server is now ready to accept connections on port 6379
2016-05-06 14:52:13 UTC [48-1] LOG:  database system was shut down at 2016-05-06 14:51:56 UTC
2016-05-06 14:52:13 UTC [48-2] LOG:  MultiXact member wraparound protections are now enabled
2016-05-06 14:52:13 UTC [31-1] LOG:  database system is ready to accept connections
2016-05-06 14:52:13 UTC [52-1] LOG:  autovacuum launcher started
supervisor pid: 33 unicorn pid: 54
30:M 06 May 14:57:14.016 * 10 changes in 300 seconds. Saving...
30:M 06 May 14:57:14.019 * Background saving started by pid 452
452:C 06 May 14:57:14.048 * DB saved on disk
452:C 06 May 14:57:14.049 * RDB: 10 MB of memory used by copy-on-write
30:M 06 May 14:57:14.120 * Background saving terminated with success
Shutting Down
run-parts: executing /etc/runit/3.d/01-nginx
ok: down: nginx: 0s, normally up
run-parts: executing /etc/runit/3.d/02-unicorn
exiting
ok: down: unicorn: 0s, normally up
run-parts: executing /etc/runit/3.d/10-redis
30:signal-handler (1462546636) Received SIGTERM scheduling shutdown...
30:M 06 May 14:57:16.727 # User requested shutdown...
30:M 06 May 14:57:16.728 * Saving the final RDB snapshot before exiting.
30:M 06 May 14:57:16.749 * DB saved on disk
30:M 06 May 14:57:16.749 # Redis is now ready to exit, bye bye...
ok: down: redis: 1s, normally up
run-parts: executing /etc/runit/3.d/99-postgres
2016-05-06 14:57:17 UTC [31-2] LOG:  received smart shutdown request
2016-05-06 14:57:17 UTC [52-2] LOG:  autovacuum launcher shutting down
2016-05-06 14:57:17 UTC [49-1] LOG:  shutting down
2016-05-06 14:57:18 UTC [49-2] LOG:  database system is shut down
ok: down: postgres: 0s, normally up
ok: down: cron: 0s, normally up
ok: down: nginx: 2s, normally up
ok: down: postgres: 0s, normally up
ok: down: redis: 2s, normally up
ok: down: rsyslog: 0s, normally up
ok: down: unicorn: 3s, normally up

Any help? Thank you!


(Sam Saffron) #2

When you remove the SSL templates does everything work?


(Luisfpinto) #3

Yes it does work when I comment the ssl certificate request from appy.ml


(Luisfpinto) #4

Any tips with this? I have checked my ssl certificates and they look well


(Sam Saffron) #5

This is the main thing that is sticking out to me … something is not right… how is memory and disk space on your system?

try:

cd /var/discourse
./launcher rebuild app
./launcher cleanup

(Luisfpinto) #6

No It is not working :confused:

I have like 100Gb of disk space so I suppose is not for that.