Promoting to leader is not working


#1

I’m a moderator on the Hopscotch Forum, and I am trying to promote a user (PopTart0219) to leader. She is currently trust level 3. When I go into her admin profile and try to change her trust level, I get the message 'There was a problem changing the user’s trust level.'
Upon inspection of the console, I see three errors. The first is 422 Unprocessable Entity error on a put request, the second a 404 not found error on a get request, and the third another 422 error on a put request. This also happened when an admin tried to do it.
Am I doing it wrong, or is this a bug? What can I do to make this user a leader?


(Daniela) #2

Just tried to do the same on my instance and the promotions works perfectly on 1.5.0.beta10.
What version of Discourse are you running?


#3

Yep, we’re using Discourse 1.5.0.beta10. I’ll try restarting my browser, see if the problem is on my side.


(Gerhard Schlager) #4

Go to the user’s profile and make sure the value of “Website” has a valid value or is empty. You’ll need to change the website if its current value is http://.

You can update your Discourse instance if you want to fix this for all your users. A validation for the Website field was added a few days ago which prevents saving user profiles that have invalid websites. Unfortunately the previous default value for that field is now invalid. The problem is now fixed, but that fix isn’t included in beta 10.


#5

Sorry, but where is the ‘Website’ value? Is it in the admin dashboard profile thing or public profile?


(Gerhard Schlager) #6

As admin, go to the user’s profile and select Preferences.

Scroll down to the Web Site field:

Make sure it’s either empty or has a valid value like http://www.example.com.


(Sam Saffron) #7

I deployed this over the weekend , bug has got to be in latest