Psychic debug request

I did something stupid: upgrading on a Friday :frowning:

tldr;

I have a site which runs after update, but the page is blank, even though the data is visible if you view source (https://ief.ttree.space/). What should I try?

Long version

The update stopped with an error in the middle, which I again stupidly didn’t note before trying again. The second time the black update ‘console’ just stayed black. But after a while, repeated refreshes on the version page appeared to show I was updated, but nothing showing on the main site.

Unfortunately it turns out my admin is away until Sunday, but I can ssh into the host, so I poked around a bit and tried doing a rebuild, but that choked on git fetch (access denied), so it looks like I don’t have full rights. After that the site wasn’t responding at all, but I managed to restart the app, but still find myself in this weird situation. There’s another topic here which suggests disabling all plugins, but I don’t know how to do that without the UI.

Any help gratefully received, I’ll check back in the morning (or rather at the other end of the morning) to answer any questions.

1 Like

On a host that has independent back ups you could log in and restore?

Er, I did a backup from inside Discourse before updating, is that an independent backup? Or do you mean a backup of the actual hosted VM?(which we probably have, but I don’t know where to look).

1 Like

Yeah the actual host, if you do auto back-ups, but you’d need the log in info of course

I had a similar experience, hosted on digital ocean and that was my fix.

1 Like

I guess if the worse comes to the worse.

1 Like

About SSH access, just to be clear, are you able to log as root?

Rebuilding should fix your issue. if rebuilding was working for you and you think it’s a plugin issue, usually, you can disable plugins in /var/discourse/containers/app.yml (check at the end with - git clone ... and insert a # before the dash). Then, you rebuild & see.

If you did a backup right before, it’s also possible to restore a previous backup by entering into Discourse app: Restore a backup from command line. Check the restore part. I don’t know if it will work if you are not logged in as root and I’m not sure it will make a difference (it won’t actually). Note: backups are usually located to /var/discourse/shared/standalone/backups/default (to retrieve the backup file name).

2 Likes

Your vendor.js file is absent. Rebuilding will probably fix this issue. (Restoring a backup will not).

So your next hurdle is

That does not sound like you “don’t have full rights” but something else is up. Do you have any idea which repo this is about?

3 Likes

Turns out there’s no backups of the host.

Nope, just as core, and I don’t have the password for > su
So looks like rebuilding might be difficult.

I had a brief moment of abject panic, because the /var/discourse/shared/standalone/backups/default folder is empty! But I found out how to do a backup from a the command line, was quite pleased with myself, but the backup disappeared again - as it gets deleted off disk once it has been copied to S3, and, you guessed it, I’ve no idea what the S3 settings or credentials are.

Thanks, good to know.

Well I’m pretty sure I don’t have rights, I tried modifying one character of launcher and got access denied there too (so it’s not specific to git fetch, it’s just that the first thing that pull does is fetch, and the first thing that fetch tries to change is ./git/FETCH_HEAD.

I’m in /var/discourse. What’s weird is that git status shows the latest commit as being from October (which is the last time we updated), but Docker Manager thinks I’m fully up to date - does the ‘current version’ file get written before the update process has got to the end.


So, I think that the conclusion is that thanks to help from you all, and previous topics here on meta, I know exactly what to do, if I could only connect as root. I guess our users will just have to wait until tomorrow when our admin gets back. And then put in place a more robust ‘disaster’ management plan. This is the downside of volunteer-provided service. It’s cheap, but not many 9’s…

1 Like

Yeah, if you’re not running as root, than that is indeed your problem.

5 Likes

Just for closure for those who were following along, the site is back up and it appears there isn’t a password so I could just have done sudo bash…

6 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.