Quote Selection Still Appears After a Selection Has Been Quoted


(Dave Mackey) #1

If you select a segment of text in a post and choose to quote the selection in your reply, it works correctly. If you then attempt to quote a second selection the pop-up appears but clicking on it doesn’t do anything.

I’d like to see the ability to have multiple selections pasted into a reply, but if this is not the intention, then it would be nice if the button to quote the selection would not appear after one has quoted one selection…or if it prompted whether one wanted to overwrite the original quoted selection.


(Anton) #2

Currently you can easily quote multiple times in a single reply.

What is more, if you post 2 times in a row (2 is configurable), then on your 3rd post an educational popup will be shown advising to quote multiple times in a single reply instead of posting multiple replies.


(Dave Mackey) #3

Weird. That wasn’t happening for me…but I just tested it and you are correct. This post can be ignored.


(cpradio) #4

Please don’t ignore this, I had this happen to me on Mobile, it doesn’t happen on Desktop though… so there may be an issue still.

Android 4.2 Chrome 36.0.1985.131

Edit: Weird, it is working now on my mobile… :frowning: I know this wasn’t working earlier…


(Anton) #5

@davidshq tell us the browser and Discourse versions, or else it’s hard to test trying to reproduce.


(Dave Mackey) #6

Windows 8.1 Pro running Chrome 36.0.1985.125 m. The Discourse version is whatever you guys are currently using on this site - I had the problem on this site today.


(Jeff Atwood) #7

Still can’t duplicate this!

That’s me selecting a second section of your post and clicking the Quote Reply button on it, too.