Raspberry Pi 4 Docker not Installed Correctly

Okay, so I have a Raspberry Pi 4 with 2GB of RAM and 1TB of storage. When I try to run
./launcher rebuild app
it’ll say Permission Denied, so I run it like
sudo bash ./launcher rebuild app
Then it’ll run. A little in, and it’ll say docker not installed correctly, so I go to the link it provides me, telling me to use an example code to see if it’ll work. When I run it, it says permission denied whenever it tried to make a connection. Is there a way to make it so the launcher runs the docker command without it being denied?

1 Like

Which distro is it?
I had been able to install successfully with Ubuntu server.

Discourse isn’t supported on ARM.

5 Likes

Putting aside the ARM incompatibilities, the Pi 4 is a very nice bump in performance indeed, but still far below what’s necessary to run Discourse.

2 Likes

Yeah I figured this one out after a while…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.