Rate Limit on Single Topic


(Mike) #1

I’m getting a rate limit error on a GET for a single topic through the API. We use discourse in an API-only way, with a Rails app proxying calls and querying data. All the traffic is therefore coming from a single IP. Is there a setting to up this limit? I’m using


(Matt Palmer) #2

Have you considered passing through the original client IP in the request? Alternately you could turn off the per-IP rate-limiting (technically, hike the threshold waaaaaaaaaay up).


(Kane York) #3

2 requests per second for the admin api key is probably too low. Twitch put in that ratelimit for their “New API” and nobody uses it.


(Mike) #4

Alternately you could turn off the per-IP rate-limiting (technically, hike the threshold waaaaaaaaaay up).

Where is this setting? I couldn’t find it!!!


(Matt Palmer) #5

The one you’re hitting is probably in nginx.