# Rebuild container error?

**URL:** <https://meta.discourse.org/t/rebuild-container-error/43740>\
**Category:** Support\
**Created:** [May 5, 2016, 3:09pm UTC](https://meta.discourse.org/t/rebuild-container-error/43740 "2016-05-05T15:09:06Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![saluzi](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/saluzi/32/77568_2.png) [@saluzi](https://meta.discourse.org/u/saluzi)\
**Post date:** [May 5, 2016, 3:09pm UTC](https://meta.discourse.org/t/rebuild-container-error/43740/1 "2016-05-05T15:09:06Z")

</div>

After I Run `./launcher rebuild app` ,Being given:

```
Removing old container
+ /usr/bin/docker rm app
Error response from daemon: Driver aufs failed to remove root filesystem 8218bb15066b2d2ce0ba527cf68f0465759c45e06abb8b2e61b7b58b9c75620f: rename /var/lib/docker/aufs/mnt/cff411f5c6bfb54c984d35ae9871d32017ec7ee4ee806e09bef0819cbcf295c1 /var/lib/docker/aufs/mnt/cff411f5c6bfb54c984d35ae9871d32017ec7ee4ee806e09bef0819cbcf295c1-removing: device or resource busy

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: Container is marked for removal and cannot be started.
Error: failed to start containers: app

```

Is this what is the reason?  
thanks！

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [May 5, 2016, 8:43pm UTC](https://meta.discourse.org/t/rebuild-container-error/43740/2 "2016-05-05T20:43:36Z")

</div>

Looks like aufs support is no longer working on your server?

---

<div class="post-metadata">

**Author:** ![vulkanino](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vulkanino/32/119654_2.png) [@vulkanino](https://meta.discourse.org/u/vulkanino)\
**Post date:** [September 15, 2016, 3:56pm UTC](https://meta.discourse.org/t/rebuild-container-error/43740/3 "2016-09-15T15:56:32Z")

</div>

I’m having the same problem now, what should I do?

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [September 15, 2016, 9:51pm UTC](https://meta.discourse.org/t/rebuild-container-error/43740/4 "2016-09-15T21:51:22Z")

</div>

Maybe remove and reinstall Docker? You’ll need aufs support for a stable filesystem.

---

<div class="post-metadata">

**Author:** ![saluzi](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/saluzi/32/77568_2.png) [@saluzi](https://meta.discourse.org/u/saluzi)\
**Post date:** [September 16, 2016, 8:11am UTC](https://meta.discourse.org/t/rebuild-container-error/43740/5 "2016-09-16T08:11:17Z")

</div>

This problem has been solved for a long time. Now there’s no similar situation.

---

<div class="post-metadata">

**Author:** ![tgxworld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tgxworld/32/106117_2.png) [@tgxworld](https://meta.discourse.org/u/tgxworld)\
**Post date:** [September 16, 2016, 8:18am UTC](https://meta.discourse.org/t/rebuild-container-error/43740/6 "2016-09-16T08:18:06Z")

</div>


