Rebuild failed why is that?


(spiral2k) #1

im on digital ocean, OS: Ubuntu 14.04 x64 with 1GB RAM.

iv rebuild the app and

FAILED

RuntimeError: ssh-import-id root failed with return #<Process::Status: pid 5553 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn’
exec failed with the params "ssh-import-id root"
08bd2ff5a94edc6dec9536bc598f5ff0b90b416ee817346d24df13373bd967ea
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

how can i get it fix? thanks!


(Jeff Atwood) #2

Did you read the words there? Did you scroll up and look for errors? What error messages do you see?


(spiral2k) #3

2015-10-20 17:54:41 UTC [84-1] postgres@postgres ERROR: database “discourse” already exists
2015-10-20 17:54:41 UTC [84-2] postgres@postgres STATEMENT: CREATE DATABASE discourse;

createdb: database creation failed: ERROR: database “discourse” already exists
I, [2015-10-20T17:54:41.405113 #43] INFO – :
I, [2015-10-20T17:54:41.412049 #43] INFO – : > su postgres -c ‘psql discourse -c “create user discourse;”’ || true
2015-10-20 17:54:41 UTC [95-1] postgres@discourse ERROR: role “discourse” already exists
2015-10-20 17:54:41 UTC [95-2] postgres@discourse STATEMENT: create user discourse;
ERROR: role “discourse” already exists

and later

I, [2015-10-20T18:07:24.527135 #43] INFO – : > ssh-import-id root
2015-10-20 18:07:25,305 INFO [0] SSH keys [Authorized]
2015-10-20 18:07:25,307 ERROR No matching keys found for [root]
I, [2015-10-20T18:07:25.310435 #43] INFO – :
I, [2015-10-20T18:07:25.324594 #43] INFO – : Terminating async processes
I, [2015-10-20T18:07:25.333233 #43] INFO – : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/9.3/bin/postmaster -D /etc/postgresql/9.3/main pid: 72
I, [2015-10-20T18:07:25.334590 #43] INFO – : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 200


(Jeff Atwood) #4

Can you paste the full log on pastebin? That’s not enough.

Also, was your site ever working, or is this a new install? If it is a new install, I recommend deleting it and starting over.


(spiral2k) #5

thanks for your support.

my site is working but i cant do a rebuild.

here is the full log:
http://pastebin.com/NCmyux0f


(Jeff Atwood) #6

Perhaps this issue? Did you ever issue a destroy command?

https://github.com/discourse/discourse_docker/issues/195


(spiral2k) #7

no, i didnt use destroy commend.

what you recommend to do with this issue ?


(Fábio Machado De Oliveira) #8

can you start it and make a backup? whatever it is a backup looks like a good idea now