# Rebuild failing "rubygems.org: too many connection resets"

**URL:** https://meta.discourse.org/t/rebuild-failing-rubygems-org-too-many-connection-resets/111144
**Category:** Self-hosting
**Created:** [9 maart 2019 om 05:42 UTC](https://meta.discourse.org/t/rebuild-failing-rubygems-org-too-many-connection-resets/111144 "2019-03-09T05:42:48Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![adorfer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/adorfer/32/82089_2.png) [@adorfer](https://meta.discourse.org/u/adorfer)
#### Post date: [9 maart 2019 om 05:42 UTC](https://meta.discourse.org/t/rebuild-failing-rubygems-org-too-many-connection-resets/111144/1 "2019-03-09T05:42:49Z")

</div>

while making an an upgrade (Ubuntu 16.04.06, older installation, not updated for at least 2-3 months)  
on CLI via “rebuild app”, i was stuck since several hours,  
the

```
su discourse -c 'bundle install --deployment --verbose --without test --without development --retry 3 --jobs 4' 

```

was rendering a message, that the ssl was failing while fetching files on [rubygems.org](http://rubygems.org).

(nevertheless, it was not always the same file which failed, so i assume there was progress during some attempts)

After several reboots of the VM, disabling IPv6 etc, **i reduced the MTU for the system to 1280** (just a shot in the dark): Voila!  
So some kind of PMTU-detection failed on me.

(in have no explanation, this is just a mention, perhaps for others who are stuck on a similar issue.)

---

<div class="post-metadata">

### Author: ![Stephen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/stephen/32/95011_2.png) [@Stephen](https://meta.discourse.org/u/Stephen)
#### Post date: [9 maart 2019 om 06:31 UTC](https://meta.discourse.org/t/rebuild-failing-rubygems-org-too-many-connection-resets/111144/2 "2019-03-09T06:31:07Z")

</div>

[Rubygems.org](http://Rubygems.org) periodically rate limits different hosts/subnets. It’s not something you did, and it’s unlikely the MTU change fixed it. There are [lots of people running into this](https://meta.discourse.org/search?q=rubygems%20rate%20limit) unfortunately. Glad it’s fixed for you now though.
