Rebuild on 1.9.1 (also 1.9.4) fails


(Ernesto Serrano) #1

Hi, I’m doing a forum rebuild of the version 1.9.1 and fails, the error is the same described here: Help .. rebuild app failed

(a dependency-horror problem with libv that produces the error LoadError: /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer_extension.so: undefined symbol: _ZTIN2v811ArrayBuffer9AllocatorE - /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer_extension.so)

We are setting a fixed tagged version in our app.yml because using stable branch can break the compatibility when you upgrade to discourse 2.0. So are you going to tag a 1.9.5 with this error fixed?

Thanks!


(Sam Saffron) #2

I recall we had issues with the stable branch but all the fixes should be backported now, afaik @RGJ helped us isolate all of these. You are going to have to rebuild with latest stable