Rebuild with "undefined method skip_before_filter" error


(Dean Peterson) #1

I have been using discourse for a long time, running fine on RHEL 7. I waited about 2 - 3 months and upgraded from 1.8 something to the latest version. CHAOS has ensued. The filesystem check has forced me to abandon RHEL entirely. No amount of adding extra hard drives and trying to modify the backing filesystem to allow d_type worked (even with a new hard drive set up for ext4 and xfs ftype=1). Nothing changed the running docker’s backing filesystem. So I switched to Ubuntu. I still can’t get things running. Amazon simple email service has forward slashes in their generated passwords. Ok, so I make a fake password to start. I tried using my old app.yml file. Ha! No way. So, I finally give up and run through an entirely fresh install. That seems to get the juices flowing but now I’m left trying to restore my old data and plugins and pray everything works. Somehow I doubt I’ll have any luck. It may not be intentional sabotage, but it sure seems like the discourse team is trying extra hard to make running discourse yourself very hard.

update: yep, i was right. Adding the plugins and running rebuild I now get “undefined method `skip_before_filter’” and the build terminates unsuccessfully.


(Angus McLeod) #2

It sounds like you’ve already figured out your issue. Your plugins need updating.


(Dean Peterson) #3

Yes, I’m hoping i can just fork the plugin since it’s no longer supported and change skip_before_filter to skip_before_action. I am just amazed at how every update has been amazingly smooth until this complete 180 where seemingly everything has broken.


(Angus McLeod) #4

Core changes break plugins sometimes. I have a bit of experience with that.

But it is far better that core Discourse keeps improving and that you need to update your plugins once in a while, than for core to stagnate.


(Dean Peterson) #5

Phew! Got it all working again. That was crazy.