# 当 MAXMIND 每日配额用尽时，重建总是失败

**URL:** <https://meta.discourse.org/t/rebuilding-always-fails-when-the-maxmind-daily-limit-is-exhausted/312775>\
**Category:** Bug\
**Tags:** maxmind, dev-ops, fixed\
**Created:** [2024年六月19日 15:13 UTC](https://meta.discourse.org/t/rebuilding-always-fails-when-the-maxmind-daily-limit-is-exhausted/312775 "2024-06-19T15:13:54Z")\
**Posts on this page:** 1\
**Showing post:** 9

<div class="post-metadata">

**Author:** ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)\
**Post date:** [2024年七月2日 09:35 UTC](https://meta.discourse.org/t/rebuilding-always-fails-when-the-maxmind-daily-limit-is-exhausted/312775/9 "2024-07-02T09:35:26Z")

</div>

> [@kuaza](#):
>
> 我也看到了 zlip 错误。

对于那个错误，你的 `app.yml` 中是否也添加了 `DISCOURSE_MAXMIND_ACCOUNT_ID`？

> [@"Zlib::BufError: buffer error" - Discourse update fails](https://meta.discourse.org/t/zlib-buffer-error-discourse-update-fails/311347/5?u=jammydodger):
>
> I’ve just had this issue when updating a Discourse install… I believe the cause is because when DISCOURSE\_MAXMIND\_LICENSE\_KEY is specified in the .yml container file without a corresponding DISCOURSE\_MAXMIND\_ACCOUNT\_ID. @tgxworld’s pull request adds the use of DISCOURSE\_MAXMIND\_ACCOUNT\_ID in multiple places and explains the need for “Account ID”: For me the fix was adding DISCOURSE\_MAXMIND\_ACCOUNT\_ID and rebuilding (I rebuilt twice, but this was most likely a temporary issue).

---

_[View the full topic](https://meta.discourse.org/t/rebuilding-always-fails-when-the-maxmind-daily-limit-is-exhausted/312775)._
