# アプリの再構築 - 奇妙なエラー

**URL:** https://meta.discourse.org/t/rebuilding-app-weird-error/358439
**Category:** Support
**Tags:** cdn
**Created:** [2025 年 3 月 22 日午後 4:06 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439 "2025-03-22T16:06:08Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![LotusJeff](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lotusjeff/32/477888_2.png) [@LotusJeff](https://meta.discourse.org/u/LotusJeff)
#### Post date: [2025 年 3 月 22 日午後 4:06 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/1 "2025-03-22T16:06:09Z")

</div>

月次メンテナンスと Discourse のアップデートを実行していたところ、再構築中に以下のエラーが発生しました。

```plaintext
I, [2025-03-22T15:54:02.806441 #1] INFO -- : > cd /var/www/discourse &amp;&amp; sudo -E -u discourse bundle exec rake s3:upload_assets
`/root` は書き込み可能ではありません。

```

および

```plaintext
I, [2025-03-22T15:54:12.239681 #1] INFO -- : > cd /var/www/discourse &amp;&amp; sudo -E -u discourse bundle exec rake s3:expire_missing_assets
`/root` は書き込み可能ではありません。

```

再構築後：

1. 新しい画像を S3 にアップロードする投稿の作成は問題なく行えます。
2. アプリに入り、rake コマンドを実行することも問題なく行えました。

何かアイデアや提案はありますか？

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [2025 年 3 月 22 日午後 4:50 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/3 "2025-03-22T16:50:29Z")

</div>

あなたはsudoとroot上にいますね、正しいですか？

---

<div class="post-metadata">

### Author: ![LotusJeff](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lotusjeff/32/477888_2.png) [@LotusJeff](https://meta.discourse.org/u/LotusJeff)
#### Post date: [2025 年 3 月 22 日午後 5:24 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/4 "2025-03-22T17:24:40Z")

</div>

すべては同じセッションで「root」の下で試行されました。

---

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [2025 年 3 月 23 日午前 10:39 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/5 "2025-03-23T10:39:25Z")

</div>

> [@LotusJeff](#):
>
> 「root」の下

しかし、プロセスはrootとして実行されていましたか？

---

<div class="post-metadata">

### Author: ![LotusJeff](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lotusjeff/32/477888_2.png) [@LotusJeff](https://meta.discourse.org/u/LotusJeff)
#### Post date: [2025 年 3 月 23 日午後 12:43 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/6 "2025-03-23T12:43:16Z")

</div>

だから質問を投稿しました。数回の再構築でこのようなことは一度も起こりませんでした。

---

<div class="post-metadata">

### Author: ![keithkhl](https://avatars.discourse-cdn.com/v4/letter/k/919ad9/32.png) [@keithkhl](https://meta.discourse.org/u/keithkhl)
#### Post date: [2025 年 8 月 2 日午後 3:15 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/7 "2025-08-02T15:15:41Z")

</div>

私も同じ状況です。

---

<div class="post-metadata">

### Author: ![keithkhl](https://avatars.discourse-cdn.com/v4/letter/k/919ad9/32.png) [@keithkhl](https://meta.discourse.org/u/keithkhl)
#### Post date: [2025 年 8 月 2 日午後 3:34 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/8 "2025-08-02T15:34:43Z")

</div>

私のケースでは、db:migrate が正常に実行されていません。

異なるバックエンドサーバーで試しましたが、すべて同じエラーメッセージが表示されました。

Postgres が 16 または 17 をサポートしていないことが原因だと当初は思っていたので、以下のフックで実行してみました。

それでも何も機能しませんでした。

```plaintext
hooks:
  after_code:
    - exec:
        cd: /var/www/discourse
        cmd:
          - export HOME=/var/www/discourse
          - export BUNDLE_USER_HOME=/var/www/discourse/.bundle
          - apt-get update
          - apt-get remove -y postgresql-client-15
          - apt-get install -y postgresql-client-16

```

---

<div class="post-metadata">

### Author: ![keithkhl](https://avatars.discourse-cdn.com/v4/letter/k/919ad9/32.png) [@keithkhl](https://meta.discourse.org/u/keithkhl)
#### Post date: [2025 年 8 月 2 日午後 5:23 UTC](https://meta.discourse.org/t/rebuilding-app-weird-error/358439/9 "2025-08-02T17:23:58Z")

</div>

ほとんどすべて追加のapp.yml項目を削除した後、PGベクトルを属性とするエラーにつまずきました。

Postgreベクトル拡張機能のインストールにより、ビルドプロセスは正常に完了しましたが、「/root書き込み不可」がまだ表示されます。
