"Recently Read Topics by User" query returns Parameter declaration error


#1

Just tried this - Recently Read Topics by User- @mcwumbly and getting the following error:
Parameter declaration error - the default value is not a valid int

I have tried also changing the :user value from 1 to my userid but still same error


What cool data explorer queries have you come up with?
(Dave McClure) #2

weird… :user param should really be an integer so I updated it above, but it was working for me anyway…


#3

strange still getting the same issue - both on 1.5 stable and latest build.

Are you able to export as json file for me please and will see if it will allow as an import.

Thanks,
Mike


(Dave McClure) #4

Here you go:

recently-read-topics-by-user.dcquery.json (774 Bytes)

FWIW, I’m on the latest build of Discourse and the plugin… Are you on the standard docker install?


(Dean Taylor) #5

There is currently a weird bug that causes this error in the Data Explorer.

I had been unable to mark down the exact sequence, but refreshing the page resolves it.


#6

Very odd - that works fine now with the imported file - thanks @mcwumbly

Did try to refresh the page @DeanMarkTaylor but that didnt seem to make any difference. I wonder if it has something to do with the params fields as most other queries run ok - but find from time to time when trying to save them i get similar errors.