Redirect always to groups after login


(Nicolás) #1

Hello guys,

I have disabled group directory in my forum, I don’t need groups at this moment. However every time an user login it redirects to /groups, getting a 404… Why isn’t redirecting to the forum homepage?

Thanks in advance


#2

Are you using SSO or native login?


(Nicolás) #3

I am using SSO, and I think it was redirecting just fine before playing with groups and finding out I don’t need them :thinking:


#4

I’d start by checking that redirect. :wink:


(Nicolás) #5

I have been doing that but I can’t find where the redirect to groups is taking action.

  1. After pressing log in it goes to:

    https://www.coincollectionmarket.com/forum/session/sso?return_path=/forum/
    
  2. In my code (php):

    if (hash_hmac('sha256', $sso, $sso_secret) != $sig)
    {
    ....
    }
    else
    {
      $payload = base64_encode($nonce. "&email=".$user["email"].
      "&external_id=".$user["id_users"]."&username=".$user["user_name"]);
    
      $return_sig = hash_hmac('sha256', $payload, $sso_secret);
    
      header("Location: https://www.coincollectionmarket.com/forum/session/sso_login?sso=". $payload ."&sig=". $return_sig);
     }
    
  3. SSO log

Verbose SSO log: User was logged on nico1005

nonce: 41151fcasds83b471bcaf12a202b0f7e
name:
username: nico1005
email: …
avatar_url:
avatar_force_update:
require_activation:
bio:
external_id: …
return_sso_url: http://coincollectionmarket.com/forum/session/sso_login
admin:
moderator:
suppress_welcome_message:
title:
add_groups:
remove_groups:
groups:

I’m out of ideas

Edit: Screenshot


(Vinoth Kannan) #6

Did you click the login button from groups page?


(Nicolás) #7

No, I was clicking from the home page. It fixed by itself after enabling the groups and creating a new group. Then I deleted the group and disable the option again. Idk what was the problem…