# Redis\_data & Postgres\_data are eating my 20GB+ Space

**URL:** https://meta.discourse.org/t/redis-data-postgres-data-are-eating-my-20gb-space/341002
**Category:** Support
**Tags:** postgres
**Created:** [December 6, 2024, 7:17pm UTC](https://meta.discourse.org/t/redis-data-postgres-data-are-eating-my-20gb-space/341002 "2024-12-06T19:17:03Z")
**Posts on this page:** 1
**Showing post:** 12

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [December 8, 2024, 12:43pm UTC](https://meta.discourse.org/t/redis-data-postgres-data-are-eating-my-20gb-space/341002/12 "2024-12-08T12:43:11Z")

</div>

As a general checkup, which includes a check for processes being killed due to shortage of memory:

> [@Failed to bootstrap on first install](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475/6):
>
> It feels possible that you have too little memory (by which I mean RAM+swap) and yet 2+4 should be enough. Please run the following quick diagnostics and post the results:
> 
> ```plaintext
> cat /etc/lsb-release
> uptime
> df -h /
> free
> swapon
> vmstat 5 5
> dmesg|egrep -i "memory|oom|kill"
> ps auxrc
> 
> ```

---

_[View the full topic](https://meta.discourse.org/t/redis-data-postgres-data-are-eating-my-20gb-space/341002)._
