Redis timeout issue while run the container image

Hi Team,
I think I have understand and configured the discourse docker images. And I have done that as well, but I am having one issue(hope this will be my last issue :wink:) mentioned below.

I have taken the image of running container and then deleted the running image and container, then I have pull the new image which I have already created with running container.

I can able to pull that image then when I ran the image with the below code I got stuck in with below error. Could someone help me to fix this issue.

Docker run command : root@mynewserver:~# docker run mydockerhub/discourse:v1

Error:

run-parts: executing /etc/runit/1.d/00-ensure-links
run-parts: executing /etc/runit/1.d/00-fix-var-logs
run-parts: executing /etc/runit/1.d/anacron
anacron: Can't chdir to /var/spool/anacron: No such file or directory
run-parts: /etc/runit/1.d/anacron exited with return code 1
Started runsvdir, PID is 31
rsyslogd: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]
rsyslogd: imklog: cannot open kernel log (/proc/kmsg): Operation not permitted.
rsyslogd: activation of module imklog failed [v8.16.0 try http://www.rsyslog.com/e/2145 ]
rsyslogd: Could not open output pipe '/dev/xconsole':: No such file or directory [v8.16.0 try http://www.rsyslog.com/e/2039 ]
timeout: down: redis: 0s, normally up, want up
timeout: down: redis: 0s, normally up, want up
timeout: down: redis: 0s, normally up, want up
ok: run: redis: (pid 864) 0s
timeout: down: postgres: 0s, normally up, want up
timeout: down: redis: 1s, normally up, want up
ok: run: redis: (pid 904) 0s
ok: run: postgres: (pid 920) 0s
supervisor pid: 898 unicorn pid: 923
config/unicorn_launcher: line 71: kill: (923) - No such process
config/unicorn_launcher: line 15: kill: (923) - No such process
(898) exiting

Like this its keep on going. so please help me to fix it many thanks in advance.

The above issue I don’t have shared folder inside the container. that shared folder will have the redis and psql files. since its not there I was not able to run it.

2 Likes