Regression in title count indicator


#1

The title used to be red when it was too short but that seems to have disappeared. Now there is a ‘x char to go’ message, but that disappears when the autosave indicator displays. I’ve spent ~15 mins trying to post a thread and wondered why I couldn’t. Turns out it was the title length, but I didn’t get an error or indicator of any kind.


(Jeff Atwood) #2

Ooops major regression! @sam will look at it asap. Total repro.


(Sam Saffron) #3

Fixed now, no idea how it ever really worked.

The only time we highlighted the tooltips was just before save, but the save was disabled. I went ahead and added some focusout events so this acts in a sane way.

cc @neil


(Jeff Atwood) #4

Er, what? These are not tooltips they are error messages.


(Sam Saffron) #5

The class is called Discourse.PopupInputTipView it’s kind of like a tooltip that pops up when there is an error. I guess I can just call them tips :slight_smile:


(Sam Saffron) #6

I am actually leaving this open for @eviltrout to sort out:

This code is being called

Thing is this.get('view') which used to be Discourse.ComposerView for the controller is no longer the correct view, its a different view. So its triggering nothing.

This code used to work, I guess it must be es6 upgrade related or some routing issue.

In particular it seems that 2 views are in play now, the one on screen, and the one the composer is pointing to.

This is leading to a few other bugs so it should be urgently fixed.


(Robin Ward) #7

Oops this is my fault. A controller should never reach directly to the view and when I adjusted the composer for plugin work I tried to fix this but forgot to finish it before I merged.

I’ve put the view reference back for now, but we really have to have it not reach into the view like this in the future.

https://github.com/discourse/discourse/commit/97715b33d5a0f231f19e89e20c45149f4c8a6d16


(Jeff Atwood) #8