Regular notifications have missing copy


(Abhishek Gupta) #1

This is some weird thing i noticed on my instance of discourse, When someone created a new topic and none have replied to it and the topic is not created by me, I see this , instead of the you will be notified only if someone mentions your @name or replies to your post.

but when i click on Regular , it changes back to normal .


(Kane York) #2

Looks like a missing translation for sure. It’s happened before.


(Sam Saffron) #3

I find it real odd that stuff goes into “regular” automatically. I will add a fallback here. but its odd.


(Jeff Atwood) #4

Yeah this implies we have a logic bug somewhere.

I guess just add the “right” text so we can at least see when it happens and it doesn’t look like an error.

(BTW @riking this isn’t a translation error, actually, though it does look that way. Rare logic state we don’t quite understand.)


(Abhishek Gupta) #5

Just in case, my instance of discourse : http://forums.awake-gaming.com/
I have updated to 0.9.7.9


(Jeff Atwood) #6

@sam did we ever add text for this 1_4 case? I hope so since I saw it a few times myself…


(Sam Saffron) #7

1_4, is super confusing to me:

“You will be notified only if someone mentions your @name because you replied to this topic”

I need to clean up the way localization is done there.


(Jeff Atwood) #8

Under what conditions can 1_4 even occur? It seems like an odd set of logic.


(Sam Saffron) #9

Whatever it was I ironed around the issue, we will always fallback to the first good localization we have.


(Sam Saffron) #10