Rel=nofollow is not added for posts by admins


(Siraj Mahmood) #1

By defaut add rel nofollow to user content is enable in our forum. But every external link do not contains rel nofollow attribute when we see these link in inspect element?
I’m confused that there is nofollow exist or not because I can not see it. See the below snapshot and please tell me how can i resolve this problem.


(Jakob Borg) #2

Are you TL3 or higher? By default you get followed links in that case.


(Siraj Mahmood) #3

I don’t know but where we can setup ??


(Siraj Mahmood) #4

All settings are default yet, after installed discourse we do not disturb any TL settings yet. How we can make it all link nofollow?


(Erick Guan) #5

Try to set Google bot UA or disable Javascript to see. Discourse offers different layouts for bot where you can find no follow attribute.


(Mittineague) #6

There are differences in how the forum is with and without JavaScript, but AFAIK rel nofollow is not one of the differences.

eg. I am logged in here with JavaScript and when inspecting a link in the “your discourse forum” topic it is nofollow

and the links in User Cards are also nofollow

This found at
Admin -> Settings -> Trust Levels (at the bottom)

The default is for Trust Level 3 and above to have nofollow removed from their links.

Once you find out your own Trust Level you will know if your links have had nofollow removed.
If you inspect a link from a member that is below Trust Level 3 do you still not see nofollow?


(Siraj Mahmood) #7

At this time I’m admin on that forum and my trust level is still basic user but still not showing nofollow with my inserted links?


(Mittineague) #8

I just tried on my localhost with a New User Admin and the link had the nofollow removed.

I haven’t tried with the default box checked (I have to run an errand) but in the meantime, have you checked the links posted by any members below Trust Level 3 that are not Admins (or Staff)?


(Jeff Atwood) #9