Replied to private message email from

(Ian Landsman) #1


So, when people from our Discourse hosted install send a private message to each other they get an email that seems to come from the default contact email address. People are replying to this and those are just being forwarded to the admins (since I have the email address at the mail server just forwarding them) rather than going to the proper person.

I understand you can’t really set the FROM to the users email, but could the reply via email setup be extended to handle these (or does it already?) so that we could point this email address at Discourse and let those PM’s be repied to via email?

(Sam Saffron) #2

You need to configure reply via email, have you read through

(Jeff Atwood) #3

You could also be using per the default notification email return address setting (which is, a no reply autoresponder) there.

(Ian Landsman) #4

OK great. So the settings and docs don’t really make that clear that that will work for the PM’s in addition to normal topics. If that’s the case I think that’s all I need.

I’m not a big fan of do not reply email accounts, literally just posted an article about it :smile: Do Not Reply to this Email

Reply by email for private messages
(jon r) #5

My experience shows, that E-Mail answers to notifications of private messages are not parsed by the reply-via-e-mail functionality; the notifications would still carry the system notification mail sender.

Am I wrong here or could something be misconfigured? Because it works for categories.

(jon r) #6

Okay, the heading of this topic is still somewhat misguiding, but still:

When I send private messages to people via discourse, they will just reply to the notification e-mail instead of clicking on the link. Therefore the responses don’t get shared to the whole private message group.

And for clarification : is this behaviour intended or not?

(Jeff Atwood) #7

Set up reply via email or use a autoresponder. There is a howto here about setting up reply via email.

(system) #8

(Sam Saffron) #9