# Reply by email SSL self signed certificate error

**URL:** https://meta.discourse.org/t/reply-by-email-ssl-self-signed-certificate-error/30868
**Category:** Support
**Created:** [07.Июль.2015 18:40:39 UTC](https://meta.discourse.org/t/reply-by-email-ssl-self-signed-certificate-error/30868 "2015-07-07T18:40:39Z")
**Posts on this page:** 1
**Showing post:** 15

<div class="post-metadata">

### Author: ![AstonJ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/astonj/32/215041_2.png) [@AstonJ](https://meta.discourse.org/u/AstonJ)
#### Post date: [10.Август.2015 17:38:19 UTC](https://meta.discourse.org/t/reply-by-email-ssl-self-signed-certificate-error/30868/15 "2015-08-10T17:38:19Z")

</div>

Ok so now I’m on the new server I am going to try to get this set up again 😄

> [@riking](#):
>
> run:
> 
> - file:  
> path: /usr/local/share/ca-certificates/aston-email.crt  
> contents: |  
> -----BEGIN CERTIFICATE-----  
> MIIGajCCBVKgAwIBAgIQCn1PE//Ffo4Be8tPBlsAZDANBgkqhkiG9w0BAQsFADBw  
> MQswCQYDVQQGEwJVUzEVMBMGA1UEChMMRGlnaUNlcnQgSW5jMRkwFwYDVQQLExB3  
> d3cuZGlnaWNlcnQuY29tMS8wLQYDVQQDEyZEaWdpQ2VydCBTSEEyIEhpZ2ggQXNz  
> dXJhbmNlIFNlcnZlciBDQTAeFw0xMzEwMjIxMjAwMDFaFw0xNjA3MDYxMjAwMDBa  
> MGoxCzAJBgNVBAYTAlVTMQswCQYDVQQIEwJOWTERMA8GA1UEBxMITmV3IFlvcmsx  
> HTAbBgNVBAoTFFN0YWNrIEV4Y2hhbmdlLCBJbmMuMRwwGgYDVQQDDBMqLnN0YWNr  
> …  
> -----END CERTIFICATE-----

The snippet above doesn’t work Kane, the app fails to bootstrap with `/pups/lib/pups/config.rb:93:in `block (2 levels) in run\_commands’: Invalid run command path (SyntaxError)`

So I’ve tried with:

```plaintext
run:
 - file:
     path: /tmp/add-cert
     chmod: +x
     contents: |
       #!/bin/bash -e
       #Download cert
       wget http://mysite.com/cert/cert.txt -O - > /usr/local/share/ca-certificates/aston-email.cert
       update-ca-certificates

 - exec: "/tmp/add-cert"

```

But on checking logs I see:

`Job exception: SSL_connect returned=1 errno=0 state=unknown state: unknown protocol`

```plaintext
/usr/local/lib/ruby/2.0.0/net/pop.rb:552:in `connect'
/usr/local/lib/ruby/2.0.0/net/pop.rb:552:in `do_start'
/usr/local/lib/ruby/2.0.0/net/pop.rb:530:in `start'
/var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:91:in `poll_pop3'
/var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:18:in `execute'
/var/www/discourse/app/jobs/base.rb:153:in `block (2 levels) in perform'

```

There was also this from last night, but I only activated reply by email earlier today:

`Job exception: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed``

Any ideas on what I could try next or what might be going wrong?

---

_[View the full topic](https://meta.discourse.org/t/reply-by-email-ssl-self-signed-certificate-error/30868)._
