"Reply-to" link in emails is showing https with a non-SSL port


(Jared Lerner) #1

Hi - I set Discourse to use https but in my email notifications it’s giving “respond” links with the http port (80):

Reply to: https://community.clarifai.com:80/

Where can I change that so that it puts 443 instead of the 80 http port?

Running this on Apache

Thanks.


(Rafael dos Santos Silva) #2

Is the site setting use_https turned on?


(Matt Palmer) #3

Do a search in your site settings and app.yml for mentions of your domain; my guess is you’ve snuck an explicit port in somewhere. It certainly isn’t usual behaviour for the URL generator to go sticking in ports where they’re not wanted.


(Jared Lerner) #4

Yep use_https is turned on


(Jared Lerner) #5

Nothing fishy in site_settings.yml. I don’t have an app.yml on my VM (at least I don’t think I do) - is there another common file I can look at?


(Matt Palmer) #6

Whatever .yml you’ve got in containers is where you need to look, as well as in the site settings UI. site_settings.yml is the list of settings, not what you’ve set them to; that’s kept in the database.


(Jared Lerner) #7

I don’t think I have a Containers folder. Is that Docker-specific?

Sorry to bug ya but this is driving me bonkers


(Felix Freiberger) #8

Yes, the container definition is Docker-specific.

Docker is the only installation method supported here.