[Resolved] Comments no longer updating


(Steven Greco) #1

Hello

I have the wp-discourse installed on my WordPress site pointing to my discourse instance. It did pull comments over initially but it has recently stopped. I have done quite a bit of changes to the site since realizing this since its a new site i am setting up. I have checked the discourse logs as well as the site logs (apache, PHP). I dot not see any errors that would cause this issue.

Is there any other debugging i can turn on to see why its no longer pulling comments over?

I will add that the plugin does post new posts on wordpress over to Discourse.

Also does the plugin cache the comments its pulls over. Cause the comments that came over when it was working still show up on the wordpress site. Just nothing new is coming over.

Thanks.


(Steven Greco) #2

from what i gather it does not seem to be pulling the feed. If i put the url in

http://forums.grimreapergamers.com/t/discourse-comment-post/14/wordpress.json?best=5&min_trust_level=1&min_score=1&min_replies=1&bypass_trust_level_score=50

I do get a feed with all the posts. is there a way to force the sync comments function to run.


(blaumeer) #3

Is the problem limited to new comments?

You either changed some setting on D or on WP that is needed to pull comments, like the D username required, or the visibility status of your forum (I see login is required for example).

Or you use some caching/optimizing/else plugin that interferes with wp-discourse, try the usual WP plugin debugging (deactivate all, activate one by one and test).


(Steven Greco) #4

no caching setup yet. will have to go though and disable everything and set what gives. Turned off login and made the forum open and that did not change anything. if that were the case i think i would have seen a permission error. but am trying anything as this point.

Its weird cause the plugin will create new topics in D that i create in WP. So its like traffic is only flowing in on direction.


(blaumeer) #5

Have you tried editing the wp-discourse plugin settings where you define min number of replies, trustlevel etc for pulling comments? Set them to 0 and see if they are pulled onto WP.


(Steven Greco) #6

ok so turned off my firewall, all plugins, opened the forum, and changed the settings to what you see below.

https://www.diigo.com/file/image/reosqeczcdrsrrsbqzbosoeabo/Discourse+‹+Grim+Reaper+Gamers+—+WordPress.jpg

COMMENTS NOW WORK. YEA!

So now i need to start turning on one by one to see what happens. I am guessing i will need to make a comment each time i turn something back on. man this is going to take awhile, I have a lot of plugins


(Steven Greco) #7

so got everything turned back on. and it turns out that having your forum option “login is required” causes it to fail. Could have sworn i tried that before. Probably did not wait long enough.

no error seems to get thrown for this.


(blaumeer) #8

Good to have a confirmation!