# Resolving an error more than a year after publishing it

**URL:** https://meta.discourse.org/t/resolving-an-error-more-than-a-year-after-publishing-it/238358
**Category:** Self-hosting
**Created:** [September 7, 2022, 5:16pm UTC](https://meta.discourse.org/t/resolving-an-error-more-than-a-year-after-publishing-it/238358 "2022-09-07T17:16:44Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Rhod](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rhod/32/507923_2.png) [@Rhod](https://meta.discourse.org/u/Rhod)
#### Post date: [September 7, 2022, 5:16pm UTC](https://meta.discourse.org/t/resolving-an-error-more-than-a-year-after-publishing-it/238358/1 "2022-09-07T17:16:44Z")

</div>

Continuing the discussion from [Error executing command "./launcher rebuild app"](https://meta.discourse.org/t/error-executing-command-launcher-rebuild-app/199017):

Seeing a topic I created a little over a year ago  
I realize that the problem I had at that time could have been easily solved, however nobody noticed it, if you look at the original post the app.yml file has a small error and it is that one of the plugins does not have at the end the “.git” and this apparently was all the problem I had, I share this because although it seems simple, it could be happening to many at the time I “solved” it by uploading another “app.yml” file that was not “corrupt” , but apparently it simply did not have the line that was added to the last plugin, therefore it worked without problems, at the time it seemed strange to me that a text editor like sublime text corrupted the file, taking into account that it is the one that always use to edit server files had never had any problems.

```plaintext
## Plugins go here
## see https://meta.discourse.org/t/19157 for details
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-voting

```

In short, I share it only as an anecdote and probably this can solve the problems of some.

And has something similar ever happened to you? That a “blunder” error has been caused by something as simple as the lack of a point or a parenthesis, etc.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [September 7, 2022, 5:24pm UTC](https://meta.discourse.org/t/resolving-an-error-more-than-a-year-after-publishing-it/238358/2 "2022-09-07T17:24:12Z")

</div>

I’m sad to say that was not the error. Rebuilds work fine without including the `.git` at the end of the repository link.

Looking at the old topic it was likely to be an invalid character as was suggested at the time. Though deleting it and creating a new one seemed to sort that out for you without needing to track it down precisely. 🎉👍

---

<div class="post-metadata">

### Author: ![Rhod](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rhod/32/507923_2.png) [@Rhod](https://meta.discourse.org/u/Rhod)
#### Post date: [September 7, 2022, 5:32pm UTC](https://meta.discourse.org/t/resolving-an-error-more-than-a-year-after-publishing-it/238358/3 "2022-09-07T17:32:29Z")

</div>

Yep is sad 🥲.

But, it’s good to know that it works without the “.git” at the end, I’ll see if by chance I still have the aforementioned file to review it thoroughly. Although I doubt it, the only thing I have is the file published in the forum, so it is most likely that it was corrupt, in the end I will see if I can reproduce said error in a test server.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [September 7, 2022, 5:36pm UTC](https://meta.discourse.org/t/resolving-an-error-more-than-a-year-after-publishing-it/238358/4 "2022-09-07T17:36:15Z")

</div>

From a quick read, my best guess is that you had tabs in your YML when you tried to add the plugin. I find it safest to copy/paste the `docker_manager` line and then edit the URL on the pasted one.
