# Реакция на ошибку «Вы не можете войти с этого IP-адреса», хотя IP не заблокирован

**URL:** https://meta.discourse.org/t/responding-to-the-error-you-can-t-log-in-from-that-ip-address-but-ip-not-blocked/384355
**Category:** Self-hosting
**Tags:** hosting
**Created:** [30.Сентябрь.2025 10:16:23 UTC](https://meta.discourse.org/t/responding-to-the-error-you-can-t-log-in-from-that-ip-address-but-ip-not-blocked/384355 "2025-09-30T10:16:23Z")
**Posts on this page:** 1
**Showing post:** 1

<div class="post-metadata">

### Author: ![gigperformer](https://avatars.discourse-cdn.com/v4/letter/g/94ad74/32.png) [@gigperformer](https://meta.discourse.org/u/gigperformer)
#### Post date: [30.Сентябрь.2025 10:16:23 UTC](https://meta.discourse.org/t/responding-to-the-error-you-can-t-log-in-from-that-ip-address-but-ip-not-blocked/384355/1 "2025-09-30T10:16:23Z")

</div>

Мы столкнулись с этой проблемой несколько недель назад, но поиски привели нас лишь к обсуждениям проблемы, а не к реальным решениям.

Однако мы обнаружили, что причина проблемы заключалась в том, что мы пытались проксировать наш сервер Discourse через Cloudflare (который уже несколько лет успешно проксирует и защищает наш основной веб-сервер), пытаясь остановить часть спам-атак от ИИ, хотя Cloudflare уже выполняет эту функцию для нашего основного веб-сервера.

Но как только мы это сделали, наши пользователи и администраторы начали видеть ошибку о невозможности входа «с этого IP-адреса». Как только мы убрали проксирование (да, это должно быть слово) для поддомена, всё снова начало работать идеально.

Это заставляет задуматься: почему проксирование через Cloudflare вызвало проблему и может ли это намекнуть на решение? Возможно, сервер Discourse определяет, что хост, на котором он запущен, имеет другой IP-адрес, чем тот, который отображается через Cloudflare? Может ли это быть причиной проблемы?

---

_[View the full topic](https://meta.discourse.org/t/responding-to-the-error-you-can-t-log-in-from-that-ip-address-but-ip-not-blocked/384355)._
