# Restarting container when internet is down causes discourse to fail

**URL:** https://meta.discourse.org/t/restarting-container-when-internet-is-down-causes-discourse-to-fail/42615
**Category:** Bug
**Created:** [April 15, 2016, 3:29pm UTC](https://meta.discourse.org/t/restarting-container-when-internet-is-down-causes-discourse-to-fail/42615 "2016-04-15T15:29:13Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [April 22, 2016, 1:20am UTC](https://meta.discourse.org/t/restarting-container-when-internet-is-down-causes-discourse-to-fail/42615/4 "2016-04-22T01:20:37Z")

</div>

The issue causing this is documented here:

> <https://stackoverflow.com/questions/32845674/nginx-how-to-not-exit-if-host-not-found-in-upstream>

I would like to change it so letter avatars are all served via the rails app which can be a lot smarter about dealing with a problem DNS entry an so on.

Just blanket failing to load NGINX cause `avatars.discourse.org` is not something we can allow.

---

_[View the full topic](https://meta.discourse.org/t/restarting-container-when-internet-is-down-causes-discourse-to-fail/42615)._
