Restore Error, i dont understand that error


#1

Hi,

i will move my Discourse Instance to a Different Server, i have found this…

Logs: [2018-02-09 13:12:50] [STARTED] [2018-02-09 13:12:51] 'Imperator' has started t - Pastebin.com

I dont know how i fix this Error ERROR: current transaction is aborted, commands ignored until end of transaction block


(Rafael dos Santos Silva) #2
[2018-02-09 13:13:43] ERROR:  could not create unique index "posts_pkey"
[2018-02-09 13:13:43] DETAIL:  Key (id)=(45676) is duplicated.

This backup has invalid data.


#3

Okay thanks,

any idea how i can fix this? :confused:


(Joshua Rosenfeld) #4

Generate a new backup.


#5

same error :frowning:

https://pastebin.com/wFEwrKcZ


#6

Not working, i have try it now 4 times same error :frowning:


#7

Nobody an idea how i can repair this? I got every time the same error.

I have try Backup with and without files.


(Neil Lalonde) #8

I don’t have any ideas about why this is happening. Is there anything about the site that you’re backing up that is unusual? Does it really have two posts with the same id? SELECT count(*) FROM posts WHERE id = 45676. I doubt it… but that backup seems to have two rows with that ID.


#9

Not that I’m sick, I have some plugins installed. But I do not think anything unusual.
Discourse was installed on 17.08.2015, have made regular updates.

I’ve installed the plugin discourse-data-explorer and done your SQL query, that’s the result

{"success":true,"errors":[],"duration":0.8,"params":{},"columns":["count"],"colrender":{},"relations":{},"rows":[[1]]}

that looks right for me


#10

I do not want to be annoying, but I really have to move the discourse soon. However, I do not know what else to try.

Every new backup has the same error.

Is there still a possibility to bring the active Discourse on another server?

What else can I do?


#11

So short feedback, every newly generated backup had the same error.

As written about the data-explorer is nothing twice, in the backup.
After deleting the double entry in the file was synonymous loading the backup.

Why all this is now only with the backup, I do not know.
The post was made by anonymous user.