# Herstellen mislukt bij "UITZONDERING: x van y uploads zijn niet gemigreerd naar S3. S3-migratie mislukt voor db 'default'."

**URL:** https://meta.discourse.org/t/restore-failed-at-exception-x-of-y-uploads-are-not-migrated-to-s3-s3-migration-failed-for-db-default/171100
**Category:** Self-hosting
**Created:** [24 november 2020 om 00:03 UTC](https://meta.discourse.org/t/restore-failed-at-exception-x-of-y-uploads-are-not-migrated-to-s3-s3-migration-failed-for-db-default/171100 "2020-11-24T00:03:21Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![RBoy](https://avatars.discourse-cdn.com/v4/letter/r/2bfe46/32.png) [@RBoy](https://meta.discourse.org/u/RBoy)
#### Post date: [9 juni 2022 om 14:20 UTC](https://meta.discourse.org/t/restore-failed-at-exception-x-of-y-uploads-are-not-migrated-to-s3-s3-migration-failed-for-db-default/171100/3 "2022-06-09T14:20:00Z")

</div>

> [@dltj](#):
>
> file long enough to disable the `enable_s3_uploads` site setting before creating the backup. I’ve now done that backup, uploaded it to the new server, restored it, and have the Discourse site running again

I’m facing the same issue here but I haven’t been able to resolve it:

> [@Help restoring - system hung at midnight](https://meta.discourse.org/t/help-restoring-system-hung-at-midnight/229486/9):
>
> Thanks, my site has crashed unfortunately so I’m only left with the S3 uploads and back ups. I’m assuming there’s no way to for me to migrate any left over local files to the S3 now. So I’m wondering what are my options right now? Is there a way to restore from S3 backups and ignore the local files? I found a way to have it ignore the S3 upload but then pretty much all the posts have broken links/images (90%+ is probably in the S3 because I setup the S3 upload many many years ago).

Could you explain in more details what exactly you did here? Was this settings disabled in the Admin → Settings GUI page or was it on in app.yml? So after the backup, you were able to restore it and get everything back? Did you turn on this setting again after the backup? Thanks

---

_[View the full topic](https://meta.discourse.org/t/restore-failed-at-exception-x-of-y-uploads-are-not-migrated-to-s3-s3-migration-failed-for-db-default/171100)._
