Restore failed. Tried to do update to site from dashboard. Failed


#1

Tried to do a restore from baackup and gave failed errors. When I attempted to update the site I got this error

******************************************************** *** Please be patient, next steps might take a while *** ******************************************************** Stopping job queue to reclaim memory, master pid is 32376 $ cd /var/www/discourse/plugins/discourse-adplugin && git fetch --tags && git reset --hard HEAD@{upstream} HEAD is now at 425b64a Merge pull request #66 from gitcoinco/feature/only-request-on-id-provided $ bundle install --deployment --without test --without development Warning: the running version of Bundler (1.16.2) is older than the version that created the lockfile (1.16.3). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`. Using rake 12.3.1 Using concurrent-ruby 1.0.5 Using i18n 1.0.1 Using minitest 5.11.3 Using thread_safe 0.3.6 Using tzinfo 1.2.5 Using activesupport 5.2.0 Using builder 3.2.3 Using erubi 1.7.1 Using mini_portile2 2.3.0 Using nokogiri 1.8.3 Using rails-dom-testing 2.0.3 Using crass 1.0.4 Using loofah 2.2.2 Using rails-html-sanitizer 1.0.4 Using actionview 5.2.0 Using rack 2.0.5 Using rack-test 1.0.0 Using actionpack 5.2.0 Using globalid 0.4.1 Using activejob 5.2.0 Using mini_mime 1.0.0 Using mail 2.7.1.rc1 Using actionmailer 5.2.0 Using activemodel 5.2.0 Using active_model_serializers 0.8.4 Using arel 9.0.0 Using activerecord 5.2.0 Using public_suffix 3.0.2 Using addressable 2.5.2 Using ast 2.4.0 Using aws-eventstream 1.0.1 Using aws-partitions 1.92.0 Using aws-sigv4 1.0.2 Using jmespath 1.4.0 Using aws-sdk-core 3.21.2 Using aws-sdk-kms 1.5.0 Using aws-sdk-s3 1.14.0 Using ember-source 2.13.3 Using execjs 2.7.0 Using barber 0.12.0 Using msgpack 1.2.4 Using bootsnap 1.3.0 Using bundler 1.16.2 Using byebug 10.0.2 Using certified 1.0.0 Using chunky_png 1.3.10 Using claide 1.0.2 Using colored2 3.1.2 Using cork 0.3.0 Using nap 1.1.0 Using open4 1.3.4 Using claide-plugins 0.9.2 Using coderay 1.1.2 Using connection_pool 2.2.2 Using cppjieba_rb 0.3.0 Using safe_yaml 1.0.4 Using crack 0.4.3 Using multipart-post 2.0.0 Using faraday 0.12.2 Using faraday-http-cache 1.3.1 Using git 1.4.0 Using kramdown 1.17.0 Using no_proxy_fix 0.1.2 Using sawyer 0.8.1 Using octokit 4.9.0 Using unicode-display_width 1.4.0 Using terminal-table 1.8.0 Using danger 5.6.3 Using diff-lcs 1.3 Using exifr 1.3.4 Using fspath 3.1.0 Using image_size 1.5.0 Using in_threads 1.5.0 Using progress 3.4.0 Using discourse_image_optim 0.26.2 Using email_reply_trimmer 0.1.12 Using ember-data-source 3.0.2 Using sprockets 3.7.2 Using ember-handlebars-template 0.7.5 Using method_source 0.8.2 Using thor 0.19.4 Using railties 5.2.0 Using jquery-rails 4.3.3 Using ember-rails 0.18.5 Using excon 0.62.0 Using fabrication 2.20.1 Using fakeweb 1.3.0 Using fast_blank 1.0.0 Using rake-compiler 1.0.4 Using fast_xor 1.1.3 Using fast_xs 0.8.0 Using fastimage 2.1.3 Using ffi 1.9.25 Using flamegraph 0.9.5 Using gc_tracer 1.5.1 Using guess_html_encoding 0.0.11 Using hashdiff 0.3.7 Using hashie 3.5.7 Using highline 1.7.10 Using hiredis 0.6.1 Using hkdf 0.3.0 Using htmlentities 4.3.4 Using http_accept_language 2.0.5 Using jaro_winkler 1.5.1 Using jwt 1.5.6 Using kgio 2.11.2 Using libv8 6.7.288.46.1 (x86_64-linux) Using rb-fsevent 0.10.3 Using rb-inotify 0.9.10 Using ruby_dep 1.5.0 Using listen 3.1.5 Using request_store 1.4.1 Using lograge 0.10.0 Using logstash-event 1.2.02 Using logstash-logger 0.26.1 Using logster 1.2.11 Using lru_redux 1.1.0 Using memory_profiler 0.9.10 Using message_bus 2.1.5 Using metaclass 0.0.4 Using mini_racer 0.2.0 Using mini_scheduler 0.8.1 Using mini_sql 0.1.10 Using mini_suffix 0.3.0 Using mocha 1.5.0 Using mock_redis 0.18.0 Using moneta 1.0.0 Using multi_json 1.13.1 Using multi_xml 0.6.0 Using mustache 1.0.5 Using nokogumbo 1.5.0 Using oauth 0.5.4 Using oauth2 1.4.0 Using oj 3.6.2 Using omniauth 1.8.1 Using omniauth-oauth2 1.5.0 Using omniauth-facebook 5.0.0 Using omniauth-github 1.3.0 Using omniauth-google-oauth2 0.5.3 Using omniauth-instagram 1.3.0 Using omniauth-oauth 1.1.0 Using ruby-openid 2.7.0 Using rack-openid 1.3.1 Using omniauth-openid 1.0.1 Using omniauth-twitter 1.4.0 Using sanitize 4.6.5 Using onebox 1.8.57 Using redis 4.0.1 Using openid-redis-store 0.0.2 Using parallel 1.12.1 Using parser 2.5.1.0 Using pg 1.0.0 Using powerpack 0.1.2 Using slop 3.6.0 Using pry 0.10.4 Using pry-nav 0.2.4 Using pry-rails 0.3.6 Using puma 3.11.4 Using r2 0.2.7 Using rack-mini-profiler 1.0.0 Using rack-protection 2.0.3 Using rails_multisite 2.0.5 Using rainbow 3.0.0 Using raindrops 0.19.0 Using trollop 2.1.2 Using rbtrace 0.4.10 Using rchardet 1.8.0 Using redis-namespace 1.6.0 Using rinku 2.0.4 Using rotp 3.3.1 Using rqrcode 0.10.1 Using rspec-support 3.7.1 Using rspec-core 3.7.1 Using rspec-expectations 3.7.0 Using rspec-mocks 3.7.0 Using rspec 3.7.0 Using rspec-html-matchers 0.9.1 Using rspec-rails 3.7.2 Using rtlit 0.0.5 Using ruby-progressbar 1.9.0 Using rubocop 0.57.2 Using ruby-readability 0.7.0 Using sass-listen 4.0.0 Using sass 3.5.6 Using sassc 1.11.4 Using seed-fu 2.3.9 Using shoulda-context 1.2.2 Using shoulda-matchers 2.8.0 Using shoulda 3.5.0 Using sidekiq 5.1.3 Using sprockets-rails 3.2.1 Using sshkey 1.9.0 Using stackprof 0.2.11 Using tilt 2.0.8 Using uglifier 4.1.11 Using unf_ext 0.0.7.5 Using unf 0.1.4 Using unicorn 5.4.0 Using webmock 3.4.2 Using webpush 0.3.2 Bundle complete! 110 Gemfile dependencies, 201 gems now installed. Gems in the group development were not installed. Bundled gems are installed into `./vendor/bundle` $ bundle exec rake multisite:migrate rake aborted! Gem::LoadError: can't activate public_suffix-2.0.5, already activated public_suffix-3.0.2 /var/www/discourse/lib/plugin_gem.rb:18:in `load' /var/www/discourse/lib/plugin/instance.rb:501:in `gem' /var/www/discourse/plugins/discourse-sync-to-dropbox/plugin.rb:7:in `activate!' /var/www/discourse/lib/plugin/instance.rb:431:in `instance_eval' /var/www/discourse/lib/plugin/instance.rb:431:in `activate!' lib/discourse.rb:164:in `block in activate_plugins!' lib/discourse.rb:161:in `each' lib/discourse.rb:161:in `activate_plugins!' /var/www/discourse/config/application.rb:223:in `<class:Application>' /var/www/discourse/config/application.rb:39:in `<module:Discourse>' /var/www/discourse/config/application.rb:38:in `<top (required)>' /var/www/discourse/Rakefile:5:in `require' /var/www/discourse/Rakefile:5:in `<top (required)>' /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/exe/rake:27:in `<top (required)>' /usr/local/bin/bundle:23:in `load' /usr/local/bin/bundle:23:in `<main>' (See full trace by running task with --trace)

Then I got this error.

# Oops

The software powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.

Detailed information about the error was logged, and an automatic notification generated. We'll take a look at it.

No further action is necessary. However, if the error condition persists, you can provide additional detail, including steps to reproduce the error, by posting a discussion topic in the site's feedback category.

(Sam Saffron) #2

You are going to need a rebuild.

cd /var/discourse
./launcher rebuild app