# Restore failing- possible Data Explorer issue

**URL:** https://meta.discourse.org/t/restore-failing-possible-data-explorer-issue/134734
**Category:** Self-hosting
**Created:** [November 30, 2019, 3:02am UTC](https://meta.discourse.org/t/restore-failing-possible-data-explorer-issue/134734 "2019-11-30T03:02:51Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![Mark\_Schmucker](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mark_schmucker/32/124810_2.png) [@Mark\_Schmucker](https://meta.discourse.org/u/Mark_Schmucker)
#### Post date: [December 1, 2019, 12:23am UTC](https://meta.discourse.org/t/restore-failing-possible-data-explorer-issue/134734/6 "2019-12-01T00:23:30Z")

</div>

It gets worse, but maybe closer to the true problem… On the hypothesis that I needed more disk space, I created a new instance from my image, this time with 100 GB, compared to 50 GB before. (Backups are 5 GB each and stored on S3.) This time I got an explicit error- “No space left on device”. Yet df shows heaps of space.

```
> [2019-11-29 22:42:58] Making sure /var/www/discourse/tmp/restores/default/2019-11-29-224258 exists...
> [2019-11-29 22:42:58] Downloading archive to tmp directory...
> [2019-11-29 22:45:46] Unzipping archive, this may take a while...
> [2019-11-29 22:51:46] No metadata file to extract.
> [2019-11-29 22:51:46] Validating metadata...
> [2019-11-29 22:51:46] Current version: 20191129144706
> [2019-11-29 22:51:46] Restored version: 20191108000414
> [2019-11-29 22:51:46] Extracting dump file...
> [2019-11-29 22:53:47] EXCEPTION: No space left on device @ io_write - /shared/tmp/restores/default/2019-11-29-224258/dump.sql

> [ec2-user@ip-172-31-47-237 discourse]$ df / -h
> Filesystem Size Used Avail Use% Mounted on
> /dev/xvda1 99G 28G 71G 28% /

```

Interestingly, there is nothing in the referenced directory:

```
> /var/www/discourse# ls /shared/tmp/*
> /shared/tmp/backups:
> < empty >
> /shared/tmp/restores:
> < empty >

```

Could it be an issue with the swap file? The EC2 instance is a t2.small with 2 GB memory, so I had long ago [created a swap file](https://meta.discourse.org/t/create-a-swapfile-for-your-linux-server/13880) on the working forum. I assume the swap file would be replicated on the new instance. I’m no expert, but I think the swapfile exists, because it wouldn’t let me create a new one, and because:

```
> /var/www/discourse# swapon -s
> Filename Type Size Used Priority
> /swapfile file 2097148 1024 -2

```

---

_[View the full topic](https://meta.discourse.org/t/restore-failing-possible-data-explorer-issue/134734)._
