# Restore process cancelled at migrating uploads to S3 step

**URL:** https://meta.discourse.org/t/restore-process-cancelled-at-migrating-uploads-to-s3-step/123233
**Category:** Support
**Created:** [17 juli 2019 om 20:58 UTC](https://meta.discourse.org/t/restore-process-cancelled-at-migrating-uploads-to-s3-step/123233 "2019-07-17T20:58:20Z")
**Posts on this page:** 1
**Showing post:** 23

<div class="post-metadata">

### Author: ![ljpp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ljpp/32/96506_2.png) [@ljpp](https://meta.discourse.org/u/ljpp)
#### Post date: [29 november 2020 om 20:13 UTC](https://meta.discourse.org/t/restore-process-cancelled-at-migrating-uploads-to-s3-step/123233/23 "2020-11-29T20:13:19Z")

</div>

So, tried to restore my 2.2GB backup and got this - the restore failed:

> EXCEPTION: 44 posts are not remapped to new S3 upload URL. S3 migration failed for db ‘default’.

I am on the 2.6b6, so a fairly recent version. The site is fairly old, from 2016.

> From time to time we run into backups were the automatic remapping and migration to S3 fails for various reasons.

This is an old topic, so any recommendation for corrective action? Having a backup I can’t actually use to restore makes me a little nervous.

Edit: I just realized I may be in the wrong thread, as this seems like the same issue

> [@Restore failed at "EXCEPTION: x of y uploads are not migrated to S3. S3 migration failed for db 'default'."](https://meta.discourse.org/t/restore-failed-at-exception-x-of-y-uploads-are-not-migrated-to-s3-s3-migration-failed-for-db-default/171100):
>
> This has been sitting as a draft on [meta.discourse.org](http://meta.discourse.org) as I worked through the issue on my Discourse server. I’ve been able to get around the problem described below, but that I couldn’t do what was effectively a disaster restore (a restore without the benefit of being able to get into the old, broken server) is concerning. (The root cause was a failed Postgres 10-to-12 upgrade, but I was able to [postpone the update](https://meta.discourse.org/t/postgresql-12-update/151236#postponing-the-update) in the Discourse app.yml file long enough to disable the enable\_s3\_uploads sit…

---

_[View the full topic](https://meta.discourse.org/t/restore-process-cancelled-at-migrating-uploads-to-s3-step/123233)._
