# Restore specific discourse backup version

**URL:** https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574
**Category:** Support
**Tags:** backups
**Created:** [August 27, 2025, 8:16pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574 "2025-08-27T20:16:43Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 27, 2025, 8:16pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/1 "2025-08-27T20:16:43Z")

</div>

I had a small discourse forum for a few years and it works well. I set up autobackups, but didn’t update discourse version for a long time.

Server died, but I have backup. Backup is from the old discourse version, about a 2 years ago. When I’m trying to install the newest version and restore from backup, it doesn’t work. When I’m trying to install old version, it isn’t possible: setup script automatically pulls new commits and latest docker image, I even found these lines in launcher script and deleted, but some internal code in docker image also checks and updates git to latest version.

What should I do? How can I run old discourse version or restore old backup on a new version?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 27, 2025, 8:43pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/2 "2025-08-27T20:43:38Z")

</div>

> [@Sailormoon](#):
>
> When I’m trying to install the newest version and restore from backup, it doesn’t work.

If you want help, you’ll need to be more specific. It should work. There’s a good chance that the issue will also not work if you were able to install the same version of Discourse that you had then.

What was the error you got when you tried to restore?

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 27, 2025, 11:38pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/3 "2025-08-27T23:38:41Z")

</div>

There is no critical errors in _./launcher logs app_ output, but forum doesn’t work. Almost all buttons doesn’t work, there is no topics, and html is looking strange (buggy start page repeats itself and can be scrolled to the bottom without limit).

I’m not professional tech guy, and I hope you can tell me which logs I can add to my report where can I find them.

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 9:46am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/4 "2025-08-28T09:46:25Z")

</div>

Does anyone know, where I can find reliable logs?

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [August 28, 2025, 9:47am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/5 "2025-08-28T09:47:58Z")

</div>

Are there any errors in `/logs` route of your forum?

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 9:55am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/6 "2025-08-28T09:55:09Z")

</div>

Problem is that I can’t access /logs - “this page doesn’t exist or private”. And I cannot log in to check it.

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [August 28, 2025, 9:57am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/7 "2025-08-28T09:57:51Z")

</div>

Try using the [admin login](https://meta.discourse.org/t/disabled-login-now-cant-login/26773/11) at `https://forum.example.com/u/admin-login`\[1\].

* * *

1. You learn something new everyday!

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 10:01am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/8 "2025-08-28T10:01:09Z")

</div>

Thanks for link, but it won’t work. It sends email, but I don’t have smtp server and using this plugin: [Disable Email Verification for Discourse Plugin](https://meta.discourse.org/t/disable-email-verification-for-discourse-plugin/280874)

Maybe, some console commands on server are possible to check what happened?

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [August 28, 2025, 10:01am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/9 "2025-08-28T10:01:36Z")

</div>

AFAIK that plugin is broken. You may not want to use it (unless you are using the remake?).

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 10:03am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/10 "2025-08-28T10:03:43Z")

</div>

There was no different solution to allow users create accounts without email confirmation, when I created a server.

Maybe it’s broken now, but I’m trying at least to restore the old version of forum.

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 10:07am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/11 "2025-08-28T10:07:24Z")

</div>

Currently I cannot access any data from forum, even I have a backup. Only forum logo and tags is shown, and all buttons are unusable.

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [August 28, 2025, 10:09am UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/12 "2025-08-28T10:09:09Z")

</div>

Ouch, that complicates things. Could you try what is mentioned here to get some logs?

> [@Where does Discourse store and show logs?](https://meta.discourse.org/t/where-does-discourse-store-and-show-logs/58022):
>
> When troubleshooting issues or errors with Discourse it is important you look at your logs. Here’s a listing of where they are and what’s in there. Your site domain Administration logs shown in the UI The Discourse admin panel contains several forms of logging: Emails that are sent, skipped, bounced, received and rejected are logged at https://=DOMAIN=/admin/email-logs and the neighboring tabs. Staff actions are logged at https://=DOMAIN=/admin/logs/staff\_action\_logs Email addresses an…

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 28, 2025, 2:17pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/13 "2025-08-28T14:17:23Z")

</div>

Did you try [safe mode](https://meta.discourse.org/t/53504?silent=true)?

And comment out the broken plugin, and maybe any other plugins you have. You can add them back once you get anything working.

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 3:36pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/14 "2025-08-28T15:36:30Z")

</div>

Rails production logs doesn’t contain critical errors, product\_errors.log is empty.

> **Unicorn error logs**
>
> unknown OID 17246: failed to recognize type of 'embeddings'. It will be treated as String. Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 2 EOFError subscribe failed, reconnecting in 1 second. Call stack /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis\_client/ruby\_connection.rb:103:in `rescue in read' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis_client/ruby_connection.rb:94:in `read' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis\_client.rb:535:in `next_event' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis/subscribe.rb:66:in `subscription' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis/subscribe.rb:17:in `subscribe' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis.rb:175:in `\_subscription' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis/commands/pubsub.rb:17:in `subscribe' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus/backends/redis.rb:293:in `global\_subscribe' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message\_bus-4.4.1/lib/message\_bus.rb:769:in `global_subscribe_thread' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus.rb:740:in `block in new\_subscriber\_thread' Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Error fetching job: Connection refused - connect(2) for 127.0.0.1:6379 Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Error fetching job: Connection refused - connect(2) for 127.0.0.1:6379 Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Error fetching job: Connection refused - connect(2) for 127.0.0.1:6379 Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Error fetching job: Connection refused - connect(2) for 127.0.0.1:6379 Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Error fetching job: Connection refused - connect(2) for 127.0.0.1:6379 Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Job exception: Connection refused - connect(2) for 127.0.0.1:6379 sidekiq-exception Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Job exception: Connection refused - connect(2) for 127.0.0.1:6379 sidekiq-exception Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Job exception: Connection refused - connect(2) for 127.0.0.1:6379 sidekiq-exception Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Job exception: Connection refused - connect(2) for 127.0.0.1:6379 sidekiq-exception Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Job exception: Connection refused - connect(2) for 127.0.0.1:6379 sidekiq-exception Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 heartbeat: Connection refused - connect(2) for 127.0.0.1:6379 Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 3 Job exception: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) sidekiq-exception Failed to report error: Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) 2 Connection refused - connect(2) for 127.0.0.1:6379 (redis://localhost:6379) subscribe failed, reconnecting in 1 second. Call stack /usr/local/lib/ruby/3.3.0/socket.rb:1219:in `__connect_nonblock' /usr/local/lib/ruby/3.3.0/socket.rb:1219:in `connect\_nonblock' /usr/local/lib/ruby/3.3.0/socket.rb:60:in `connect_internal' /usr/local/lib/ruby/3.3.0/socket.rb:141:in `connect' /usr/local/lib/ruby/3.3.0/socket.rb:647:in `block in tcp' /usr/local/lib/ruby/3.3.0/socket.rb:231:in `each' /usr/local/lib/ruby/3.3.0/socket.rb:231:in `foreach' /usr/local/lib/ruby/3.3.0/socket.rb:637:in `tcp' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis\_client/ruby\_connection.rb:120:in `connect' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis_client/connection_mixin.rb:11:in `reconnect' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis\_client.rb:769:in `block in connect' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis_client/middlewares.rb:12:in `connect' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis\_client.rb:768:in `connect' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis_client.rb:759:in `raw\_connection' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis\_client.rb:719:in `ensure_connected' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-client-0.25.2/lib/redis_client.rb:314:in `call\_v' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis/client.rb:90:in `call_v' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rack-mini-profiler-4.0.1/lib/mini_profiler/profiling_methods.rb:90:in `block in profile\_method' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis.rb:152:in `block in send_command' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis.rb:151:in `synchronize' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis.rb:151:in `send_command' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-5.4.0/lib/redis/commands/strings.rb:191:in `get' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message\_bus-4.4.1/lib/message\_bus/backends/redis.rb:366:in `process_global_backlog' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus/backends/redis.rb:279:in `block in global\_subscribe' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message\_bus-4.4.1/lib/message\_bus/backends/redis.rb:291:in `global_subscribe' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus.rb:769:in `global\_subscribe\_thread' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message\_bus-4.4.1/lib/message\_bus.rb:740:in `block in new\_subscriber\_thread' unknown OID 17246: failed to recognize type of 'embeddings'. It will be treated as String.

Sidekiq logs are empty.

No problems in Nginx logs.

I see redis connection problem in Unicord logs, but Redis logs itself have no errors:

> ****
>
> 9706:C 28 Aug 2025 15:11:25.025 \* Fork CoW for RDB: current 1 MB, peak 1 MB, average 0 MB 881:M 28 Aug 2025 15:11:25.106 \* Background saving terminated with success 881:M 28 Aug 2025 15:16:26.096 \* 100 changes in 300 seconds. Saving... 881:M 28 Aug 2025 15:16:26.097 \* Background saving started by pid 10037 10037:C 28 Aug 2025 15:16:26.109 \* DB saved on disk 10037:C 28 Aug 2025 15:16:26.109 \* Fork CoW for RDB: current 1 MB, peak 1 MB, average 0 MB 881:M 28 Aug 2025 15:16:26.198 \* Background saving terminated with success 881:M 28 Aug 2025 15:21:27.004 \* 100 changes in 300 seconds. Saving... 881:M 28 Aug 2025 15:21:27.004 \* Background saving started by pid 10365 10365:C 28 Aug 2025 15:21:27.019 \* DB saved on disk 10365:C 28 Aug 2025 15:21:27.019 \* Fork CoW for RDB: current 1 MB, peak 1 MB, average 0 MB 881:M 28 Aug 2025 15:21:27.105 \* Background saving terminated with success 881:M 28 Aug 2025 15:26:28.030 \* 100 changes in 300 seconds. Saving... 881:M 28 Aug 2025 15:26:28.031 \* Background saving started by pid 10703 10703:C 28 Aug 2025 15:26:28.050 \* DB saved on disk 10703:C 28 Aug 2025 15:26:28.051 \* Fork CoW for RDB: current 1 MB, peak 1 MB, average 0 MB 881:M 28 Aug 2025 15:26:28.132 \* Background saving terminated with success 881:M 28 Aug 2025 15:31:29.094 \* 100 changes in 300 seconds. Saving... 881:M 28 Aug 2025 15:31:29.095 \* Background saving started by pid 11028 11028:C 28 Aug 2025 15:31:29.109 \* DB saved on disk 11028:C 28 Aug 2025 15:31:29.110 \* Fork CoW for RDB: current 1 MB, peak 1 MB, average 0 MB 881:M 28 Aug 2025 15:31:29.196 \* Background saving terminated with success

Postgresql logs have no errors.

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 3:37pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/15 "2025-08-28T15:37:47Z")

</div>

How can I enable it?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 28, 2025, 3:46pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/16 "2025-08-28T15:46:26Z")

</div>

Sorry. I typed “safe-mode” instead of “[safe mode](https://meta.discourse.org/t/53504?silent=true)” and didn’t notice that it wasn’t auto-linked.

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 6:00pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/17 "2025-08-28T18:00:32Z")

</div>

Thanks, it helped and forum is working (not properly, but I can access topics with contect).

However, forum without [safe mode](https://meta.discourse.org/t/53504?silent=true) is unusable, and I don’t exactly remember which plugins I installed. List of plugins should be in app.yml, but server is dead and I have only backup, which doesn’t contain app.yml, as I know. What should I do to restore forum and remove broken plugins?

---

<div class="post-metadata">

### Author: ![Canapin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/canapin/32/119591_2.png) [@Canapin](https://meta.discourse.org/u/Canapin)
#### Post date: [August 28, 2025, 7:06pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/18 "2025-08-28T19:06:43Z")

</div>

Restoring without using an existing `app.yml` shouldn’t install any plugin except the bundled ones (which are all official).

However, themes and theme components are included in the backup, so try deactivating them.

You can also try using the [safe mode](https://meta.discourse.org/t/53504?silent=true) and disable only themes and components to be sure your issues are caused by one of them.

---

<div class="post-metadata">

### Author: ![Sailormoon](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@Sailormoon](https://meta.discourse.org/u/Sailormoon)
#### Post date: [August 28, 2025, 7:10pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/19 "2025-08-28T19:10:09Z")

</div>

Thanks, it really works only without themes, but where can I find themes? In backup I see only two items: dump.sql.gz and uploads folder, that contains only user media and files.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 28, 2025, 8:43pm UTC](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574/20 "2025-08-28T20:43:27Z")

</div>

You can just access the themes from the admin interface. You can first disable them all and then turn them on one at a time (or whatever).

[Next page](https://meta.discourse.org/t/restore-specific-discourse-backup-version/380574.md?page=2)
