# Rollback upgrades

**URL:** <https://meta.discourse.org/t/rollback-upgrades/116074>\
**Category:** Self-hosting\
**Created:** [April 26, 2019, 4:19pm UTC](https://meta.discourse.org/t/rollback-upgrades/116074 "2019-04-26T16:19:09Z")\
**Posts on this page:** 1\
**Showing post:** 9

<div class="post-metadata">

**Author:** ![eatcodetravel](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/eatcodetravel/32/94385_2.png) [@eatcodetravel](https://meta.discourse.org/u/eatcodetravel)\
**Post date:** [April 26, 2019, 5:13pm UTC](https://meta.discourse.org/t/rollback-upgrades/116074/9 "2019-04-26T17:13:37Z")

</div>

> [@Stephen](#):
>
> Rebuilds don’t fail spontaneously,

Well, it did in this case. The server hasn’t changed at all since our last update. And it failed in the process of creating a Docker image with Docker, which should isolate the environment for these things not to happen. If you see is a permissions issue, I fixed it with an extra step in the `app.yml` which shouldn’t be required.

What I’m asking is how I run the old docker container before the rebuild the failed. It is already created with a previous version of Discourse so it should be possible to run it.

I had to trace down the issue and fix it before the site going up again (3 hours of downtime). If things like this happen there should be a way to run the previous docker image you had while you debug the upgrade. Even if it’s not a simple command like `./launcher start app`

---

_[View the full topic](https://meta.discourse.org/t/rollback-upgrades/116074)._
