Ruby2.6 required for 2.4.1?

Hi,

while updating to 2.4.1 I noticed, that ruby2.6 is required now:

Fetching gem metadata from https://rubygems.org/.........
actionview_precompiler-0.2.2 requires ruby version >= 2.6, which is incompatible with the current version, ruby 2.5.5p157

Is this intended? On github ruby2.5+ is still listed as requirement.

Thanks,
Alex

We will certainly fix the documentation up, it is out of date we require ruby 2.6.5

5 Likes

That’s a pitty. The current stable version of debian (buster) is shipping with ruby-2.5.1.

Why is this a problem? Could you elaborate?

1 Like

I am currently using discourse without docker and with the ruby version from the package manager. I think I have to use rvm now…

(Yes I know, the only officially supported installs are docker based, but I currently cannot use docker.)

1 Like

Updated the documentation.

Can you elaborate here?

3 Likes

Hi @techAPJ,

Also redis version should be updated? Minimum is 4.0.0 as of v2.5.0.beta1 if I’m not mistaken. (More concretely GitHub - mperham/sidekiq at v6.0.5)

Cheers,
Ismael

4 Likes

That is correct. Updated required version for Redis as well.

4 Likes