# \`run\_second\_factor!\` échoue lors de la tentative de promotion d'admin

**URL:** https://meta.discourse.org/t/run-second-factor-failing-when-trying-to-promote-admin/314516
**Category:** Support
**Created:** [Juillet 1, 2024, 9:30 UTC](https://meta.discourse.org/t/run-second-factor-failing-when-trying-to-promote-admin/314516 "2024-07-01T21:30:13Z")
**Posts on this page:** 1
**Showing post:** 9

<div class="post-metadata">

### Author: ![Osama](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/osama/32/98013_2.png) [@Osama](https://meta.discourse.org/u/Osama)
#### Post date: [Juillet 2, 2024, 8:18 UTC](https://meta.discourse.org/t/run-second-factor-failing-when-trying-to-promote-admin/314516/9 "2024-07-02T20:18:05Z")

</div>

> [@pfaffman](#):
>
> `Completed 403 Forbidden in 6ms (Views: 0.1ms | ActiveRecord: 0.0ms | Allocations: 2263)`

L’erreur 403 est normale et attendue — l’application frontend intercepte la réponse 403 et l’interprète comme « impossible d’accorder les droits d’administrateur car l’authentification à deux facteurs est requise, naviguons vers la page d’authentification à deux facteurs ».

Ce qui n’est pas normal, c’est :

> [@pfaffman](#):
>
> il y a `An unhandled server error has occurred.` (Une erreur serveur non gérée s’est produite.)

Pouvez-vous me dire où vous voyez cette erreur ? Est-ce une fenêtre pop-up dans le frontend ? Une erreur dans les logs ? Comme vous le mentionnez, je ne trouve pas ce message d’erreur dans tout l’historique du code, c’est donc très étrange.

---

_[View the full topic](https://meta.discourse.org/t/run-second-factor-failing-when-trying-to-promote-admin/314516)._
