# Running 2 hosts behind haproxy fails with random 404s

**URL:** https://meta.discourse.org/t/running-2-hosts-behind-haproxy-fails-with-random-404s/150663
**Category:** Self-hosting
**Created:** [May 6, 2020, 11:16pm UTC](https://meta.discourse.org/t/running-2-hosts-behind-haproxy-fails-with-random-404s/150663 "2020-05-06T23:16:08Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [May 6, 2020, 11:42pm UTC](https://meta.discourse.org/t/running-2-hosts-behind-haproxy-fails-with-random-404s/150663/3 "2020-05-06T23:42:45Z")

</div>

If you are running more than one web container you need something to ensure both have access to the static files.

The easiest path is [Using Object Storage for Uploads (S3 Clones)](https://meta.discourse.org/t/using-object-storage-for-uploads-s3-clones/148916)

---

_[View the full topic](https://meta.discourse.org/t/running-2-hosts-behind-haproxy-fails-with-random-404s/150663)._
