# Discourse draaien naast LAMP

**URL:** https://meta.discourse.org/t/running-discourse-alongside-lamp/171400
**Category:** Self-hosting
**Created:** [26 november 2020 om 11:28 UTC](https://meta.discourse.org/t/running-discourse-alongside-lamp/171400 "2020-11-26T11:28:43Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Enrico\_Enrico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/enrico_enrico/32/201094_2.png) [@Enrico\_Enrico](https://meta.discourse.org/u/Enrico_Enrico)
#### Post date: [26 november 2020 om 11:28 UTC](https://meta.discourse.org/t/running-discourse-alongside-lamp/171400/1 "2020-11-26T11:28:43Z")

</div>

Hello,  
I’m running Discourse on LAMP. I already have a Wordpress setup running on apache2.  
When trying to install Discourse, I get the common “port 80 already in use” error.  
In the error message I get a link to [Run other websites on the same machine as Discourse](https://meta.discourse.org/t/17247) but this topic explains how to fix the problem on a Nginx webserver. Is there any guide for apache?  
Thank you

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [26 november 2020 om 11:34 UTC](https://meta.discourse.org/t/running-discourse-alongside-lamp/171400/2 "2020-11-26T11:34:37Z")

</div>

[How to set up Discourse on a server with existing Apache sites](https://meta.discourse.org/t/how-to-set-up-discourse-on-a-server-with-existing-apache-sites/30013)

---

<div class="post-metadata">

### Author: ![Enrico\_Enrico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/enrico_enrico/32/201094_2.png) [@Enrico\_Enrico](https://meta.discourse.org/u/Enrico_Enrico)
#### Post date: [26 november 2020 om 15:56 UTC](https://meta.discourse.org/t/running-discourse-alongside-lamp/171400/3 "2020-11-26T15:56:16Z")

</div>

root: discourse# ./launcher start app

starting up existing container

- /usr/bin/docker start app  
Error response from daemon: driver failed programming external connectivity on endpoint app (e07f48c917b0406e11ff8959629a043bb77aec17fd490658be303000661de85d): Error starting userland proxy: listen tcp 0.0.0.0:443: listen: address already in use  
Error: failed to start containers: app

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [26 november 2020 om 16:23 UTC](https://meta.discourse.org/t/running-discourse-alongside-lamp/171400/4 "2020-11-26T16:23:51Z")

</div>

You will want to edit the app.yml file and comment out the SSL and Let’s Encrypt templates at the top. Also remove the comment from the socketed template, save and rebuild.

That will make Discourse listen to a unix socket, which you can use to proxy from your Apache.
