Running old version of component on newer Discourse causes site to fail

While the like button worked perfectly well from telegram.
My website has crashed. When I open, no error comes, no 404 msg, just the blank screen.
Even is working. But the website has stopped working.

I’m afraid, I ran the below given command in ignorance, and aborted it with Ctrl+C about just when it was beginning to run after giving a small warning.

wget -qO- | sh

I ran the above command before the app-rebuild command. And even I checked for once that my website was working ok after running the above command and only then I commanded app rebuild ( sudo ./launcher rebuild app) to update all plugins.

And now my website isn’t opening.
I’m trying anxiously to find what went wrong.

Can you pls give it a look?

You can try running

./launcher rebuild app



1 Like

Discourse doctor only tells/shows my configuration.
And rebuilding has been tried 2-3 times by me (by disabling all plugins also).
app.yml has been validated ok.

Output of discourse doctor is here.
I’ve restored my instance from docker backup.
But as soon as I try rebuilding (without changing anything, or by disabling all plugins), the website breaks.
The thing is that if I go to, it shows all my posts lists. But the home page doesn’t work.

I just tried getting to your site and it’s up and running from what I can tell.


I’ve restored old docker backup to/of my main website: (but problem is that 1, its not current and 2nd, I’ve found that as/if I run rebuild command on this site, even by disabling all plugins, the site fails. But only mysite/admin/upgrades page works).

And to find fault, I have created the replica docker image of today’s broken site at:
Doctor command’s log is here.

I’m seeing an error in the console about tiles_add_images_prompt

This indicates that you have an out of date version of the tiles component.

The component has already been fixed, but you’re still running an older version of it on a newer version of Discourse and that’s why your facing the issue you’re describing.

Can you update the component and see if that solves your issue?

You’d first need to enter safe-mode or

then navigate to the admin > customize and then you can update the component.

The issue should go away once you do that.

Do note that we’re working on making themes / components that have errors degrade gracefully, so what you’re experiencing is transitory and won’t happen in future versions of Discourse.


Yes. My dummy site has started working. When we are struck so bad , the person helping is no less than saint.

Now (since I’m working hard on these things - backing up, restoring, creating new images etc- for 4 hours), I’ll take 30 min break and then come back to my main site and apply this to that site.

Hope all would work well.

You’re great.

Everything is salvaged and now, I WILL SLEEP WELL. :clap::clap::clap:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.