Russian localization trouble


(Олексей же) #1

Hello. After update to 1.15 there is no ru.filters.new.title.few key for russian translation. I’ve added this key to client.ru.yml. What i need to do for translation work correctly?
https://imgur.com/yQdWS3B


(Gerhard Schlager) #2

I don’t recommend editing the locale files manually. All translation work should be done in Transifex.

Most pluralization issues should be fixed soon. There’s a PR waiting to be merged.
That said, the mentioned PR doesn’t change the filters key. I intentionally didn’t change it, so it’s still not pluralized.

Do you really need to have different translations for “Unread” depending on the count even though the count is just shown within parenthesis and not really part of the text? Currently the Russian translation looks like this.


(Олексей же) #3

How can I disable the header ru.filters.new.title.fev and leave only badges with the counter?


(Gerhard Schlager) #4

I’m not complelty sure what you’re asking, but I’d say reverting the changes you made would be an option.


(Олексей же) #5

Hello again. After few updates problem is still there. In Russian localization i see this But in English localization all work fine How i can add translation to this title?


(Gerhard Schlager) #6

It will be fixed, but you’ll have to wait a little bit longer.


(Олексей же) #7

Is there any way to fix it locally?


(Gerhard Schlager) #8

If you know what you are doing, you can edit the client.ru.yml file and add the missing few keys manually. Don’t forget to use the %{count} placeholder for those translations.