Scrolling is not smooth in Google Chrome because of auto link change in my address bar


(Anton) #1

For example lets look at any topic with loooong content, like this:

What is wrong with PHPBB?

When I scroll up and down by mouse, I feel really uncomfortable because everything is not smooth like it used to be with any pages that I scroll in my browser.

This happens because of automatic URL update in my browser’s address bar. The feature itself is excellent and right, but it really annoys me (the reader!).

Really, it used to be very smooth with any webpage when I scroll it, but not with Discourse.
Even more, my mouse it blinking while I scroll, and the favicon in the tab is blinking too. It just looks like something is wrong, but you do not understand what exactly until you catch this blinking of the mouse and of the icon.

It behaves like when you have a very old computer with very slow processor and with on-board videocard.

My proposition is to find a way to fix it because it is very serious GUI bug from the user point of view.

I’m not yet sure on how to fix it - sorry it is not very constructive to report a usability problem and not to propose a way to fix it… At least update browser url when user stops scrolling, just in few moments after this, or when mouse leaves scrollbar rectangle (if scrolled with scrollbar).

P.S. Trying Discourse on Win7 x64, Chrome.


(Anton) #2

Also, please compare visually to how this page scrolls:
http://affiliatex.com/traffic

It also has auto-loading of next links, but it scrolls completely smooth with no distraction, the same like you see when you scroll on iPhone or any browser in android os.

Please it is important to fix this.

My guess - maybe some heavy js processing happens all the time while you scroll and this freezes the browser somehow, and scrolling behavior becomes not smooth.


(Neil Lalonde) #3

It’s smooth in chrome for me. Why does the URL update cause it to not be smooth? I’m using Chrome 25.0.1364.152 on OS X.


(Anton) #4

Just checked it again in Version 25.0.1364.97 m
It blinks all the time when I scroll.
Compared to other pages and it does not blink when I scroll, definitely - I made the test many times and I can provide Teamviewer session so you can see it (just not sure if TV will show that blinking in 10 frames per second).

I also tried in FF - it looks ok there.

In IE it looks the best btw.


(Jeff Atwood) #5

This is a quirk of Google Chrome on Windows and should be addressed to their bug tracker.


(sparr) #6

I am using Chrome 26.0.1410.43 on OSX 10.7 and I see part of this issue. My scrolling is smooth, so I see no problem there, but there are other annoying behaviors:

Each time the URL changes the refresh button for the page flickers to an active loading/stop button for a moment, and the favicon flickers to blank and back to the discourse logo.


(Anton) #7

Hm true, it’s much better in Firefox.


(Anton) #8

Bug reported to Chrome:
https://code.google.com/p/chromium/issues/detail?id=271182


(Ben T) #9

Just curious, does this happen when chrome://flags/#enable-smooth-scrolling is enabled on windows? On OS X it seems to be on by default. I doubt this link will work, but you can copy and paste it.


(Anton) #10

Yes it does. It was disabled in my Chrome (still marked as experimental), but I did not notice any difference when I enabled it.


(Jeff Atwood) #11

We made changes a while ago to only change the URL when scrolling pauses. This issue is mostly particular to Chrome, but the on pause works better in most browsers.


(Jeff Atwood) #12