Scrypt dependency for plugin


#1

I am trying to add scrypt support for a plugin, and I can’t seem to find the magical gem invocations to make discourse happy, these last 3 commits are what I tried so far:

basically:

gem 'scrypt', '3.0.1'

Well that won’t compile, ffi-compiler not found, so I tried:

gem 'rake', '11.2.2'
gem 'ffi', '1.9.14'
gem 'ffi-compiler', '1.0.1'
gem 'scrypt', '3.0.1'

So now a different version of ffi is loaded already, so:

gem 'rake', '>= 11.2.2'
gem 'ffi', '>= 1.0.0'
gem 'ffi-compiler', '>= 1.0.0'
gem 'scrypt', '3.0.1'

Now it won’t install scrypt for some reason, same for:

gem 'rake'
gem 'ffi'
gem 'ffi-compiler'
gem 'scrypt', '3.0.1'

I’m pulling my hair out, what simple thing am I doing wrong? :slight_smile: