Selecting post urls in android web browser is kicking my &#*


(Tobias Eigen) #1

This morning I tried using my android phone to copy and paste a discourse URL from chrome into an email I was composing, and the UX did not let me. This must be a bug in android but I haven’t had this problem on other websites. Here’s what I am trying to do:

  1. log into my discourse and look at a topic
  2. select the chain link to copy the direct URL for the post
  3. the URL is already selected and here I should be able to copy the URL to the clipboard

I get stuck on #3. There is no option to copy to clipboard. I then try to select the URL to pull up the selection options and they do appear briefly across the top of the screen. Immediately though they are covered by another menu that does not go away and so I can’t do anything. I then select the URL again but then the selection goes away and I have to try to select it again but can’t see the whole URL.

Anyway, you get the point. I got stuck and had to wait until I was at a computer to get the URL. There is probably some trick I am missing but it should be easier! :frowning:

A related question: is there an easy way to infer a short URL from the address bar, similar to the /raw/nnn format? e.g. /t/nnn? Did not work when I tried it.

Edit: I just asked this last question elsewhere where it fits better:


How should short links be supported in Discourse
(Jeff Atwood) #2

You want the above button, which is “select all”. Android is kind of persistently crappy on the UI front, IMO, and I say that as a person who has switched to Android on the Nexus 5.

So the sequence is:

  1. click link / share button
  2. link dialog appears
  3. tap in the field
  4. tap the “select all” button
  5. tap the “copy” button (the two documents stacked there at top right)

(Dave McClure) #3

Damn! I’ve been using this for months now on a nexus 5 and never realized that is the select all button. There’s a way to select the URL without it, but it is a pain, so I won’t bother trying to explain…


(Jeff Atwood) #4

This is exactly my problem with Android. Really terrible UI still. It is so completely the Windows 3.1 of mobile. It works… for the most part… but it’s not really polished or elegant at all.


(Tobias Eigen) #5

thanks! glad to see I am not alone in this. on my android the icon is even different but it turns out it is indeed a select all button.


(Jeff Atwood) #6

Note that @neil fixed this by making the share dialog a simple link rather than a text box on touch devices. It works much better that way, tap n’ hold…


(Jeff Atwood) #7