# 自托管 - 何时重建 mail-receiver？

**URL:** <https://meta.discourse.org/t/self-hosting-when-to-rebuild-mail-receiver/389629>\
**Category:** Support\
**Tags:** mail-receiver\
**Created:** [2025年十一月25日 18:38 UTC](https://meta.discourse.org/t/self-hosting-when-to-rebuild-mail-receiver/389629 "2025-11-25T18:38:17Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![denvergeeks](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/denvergeeks/32/327671_2.png) [@denvergeeks](https://meta.discourse.org/u/denvergeeks)\
**Post date:** [2025年十一月25日 18:38 UTC](https://meta.discourse.org/t/self-hosting-when-to-rebuild-mail-receiver/389629/1 "2025-11-25T18:38:17Z")

</div>

我自行托管了多个使用 mail-receiver 的 Discourse 实例。我注意到了下面的对话，想知道——我是否需要为这些站点重建 mail-receiver.yml 文件？

> [@Remove smtp\_should\_reject & discourse-smtp-fast-rejection](https://meta.discourse.org/t/remove-smtp-should-reject-discourse-smtp-fast-rejection/389368):
>
> Continuing the discussion from [Seeing smtp\_should\_reject "400 bad request" failures on bounce processing](https://meta.discourse.org/t/seeing-smtp-should-reject-400-bad-request-failures-on-bounce-processing/387431/14): I’m making this topic to summarise some internal discussion we’ve had. We’ve identified that the codepath in smtp\_should\_reject is not functioning correctly and causing mail to be rejected in situations where it should not be. Specifically: bounce messages (having a null envelope-from) forwarded mail to mismatch (the fast-rejection check used the envelope-to, whereas Discourse uses the…

---

<div class="post-metadata">

**Author:** ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)\
**Post date:** [2025年十一月25日 20:42 UTC](https://meta.discourse.org/t/self-hosting-when-to-rebuild-mail-receiver/389629/2 "2025-11-25T20:42:53Z")

</div>

您可以更新 mail-receiver 或 Discourse 中的任一个来解决此问题。

---

<div class="post-metadata">

**Author:** ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)\
**Post date:** [2025年十二月25日 20:43 UTC](https://meta.discourse.org/t/self-hosting-when-to-rebuild-mail-receiver/389629/3 "2025-12-25T20:43:02Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
