Sending test email failed


(grahamtrump) #1

I got the error: There was a problem sending the test email. Please double-check your mail settings, verify that your host is not blocking mail connections, and try again.

And here is email info in yml (I use the Gsuite Email)
DISCOURSE_SMTP_ADDRESS: smtp.gmail.com
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_USER_NAME: abc@xyz.com
DISCOURSE_SMTP_PASSWORD: “password123”
DISCOURSE_SMTP_ENABLE_START_TLS: true # (optional, default true)

On the Gsuite Email Advanced Settings I already set the SMTP Relay Setting as below:
Allowed senders: Only addresses in my domains
Only accept mail from the specified IP addresses: Yes
Allowed IP addresses: digitalocean
Require SMTP Authentication: No
Require TLS encryption: Yes

Yesterday all email is sending OK, but today is failed.

And here is the error log

/usr/local/lib/ruby/2.5.0/net/smtp.rb:981:in check_auth_response' /usr/local/lib/ruby/2.5.0/net/smtp.rb:736:inauth_plain’ /usr/local/lib/ruby/2.5.0/net/smtp.rb:728:in authenticate' /usr/local/lib/ruby/2.5.0/net/smtp.rb:565:indo_start’ /usr/local/lib/ruby/2.5.0/net/smtp.rb:518:in start' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/mail-2.7.1.rc1/lib/mail/network/delivery_methods/smtp.rb:109:instart_smtp_session’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/mail-2.7.1.rc1/lib/mail/network/delivery_methods/smtp.rb:100:in deliver!' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/mail-2.7.1.rc1/lib/mail/message.rb:2159:indo_delivery’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/mail-2.7.1.rc1/lib/mail/message.rb:260:in block in deliver' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/actionmailer-5.2.0/lib/action_mailer/base.rb:560:inblock in deliver_mail’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/notifications.rb:168:in block in instrument' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/notifications/instrumenter.rb:23:ininstrument’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/notifications.rb:168:in instrument' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/actionmailer-5.2.0/lib/action_mailer/base.rb:558:indeliver_mail’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/mail-2.7.1.rc1/lib/mail/message.rb:260:in deliver' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/actionmailer-5.2.0/lib/action_mailer/message_delivery.rb:114:inblock in deliver_now’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/actionmailer-5.2.0/lib/action_mailer/rescuable.rb:17:in handle_exceptions' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/actionmailer-5.2.0/lib/action_mailer/message_delivery.rb:113:indeliver_now’ /var/www/discourse/lib/email/sender.rb:189:in send' /var/www/discourse/app/jobs/regular/user_email.rb:43:inexecute’ /var/www/discourse/app/jobs/base.rb:134:in block (2 levels) in perform' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/rails_multisite-2.0.5/lib/rails_multisite/connection_management.rb:63:inwith_connection’ /var/www/discourse/app/jobs/base.rb:129:in block in perform' /var/www/discourse/app/jobs/base.rb:125:ineach’ /var/www/discourse/app/jobs/base.rb:125:in perform' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:187:inexecute_job’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:169:in block (2 levels) in process' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/middleware/chain.rb:128:inblock in invoke’ /var/www/discourse/lib/sidekiq/pausable.rb:80:in call' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/middleware/chain.rb:130:inblock in invoke’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/middleware/chain.rb:133:in invoke' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:168:inblock in process’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:139:in block (6 levels) in dispatch' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/job_retry.rb:98:inlocal’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:138:in block (5 levels) in dispatch' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq.rb:36:inblock in <module:Sidekiq>’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:134:in block (4 levels) in dispatch' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:199:instats’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:129:in block (3 levels) in dispatch' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/job_logger.rb:8:incall’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:128:in block (2 levels) in dispatch' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/job_retry.rb:73:inglobal’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:127:in block in dispatch' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/logging.rb:48:inwith_context’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/logging.rb:42:in with_job_hash_context' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:126:indispatch’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:167:in process' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:85:inprocess_one’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/processor.rb:73:in run' /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/util.rb:16:inwatchdog’ /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/util.rb:25:in `block in safe_thread’


(Jay Pfaffman) #2

Sounds similar to Sidekiq queue too large - Google email provider problems.

You should switch to mallgun or another recommended mask service. If you don’t want to do that then you should contact Google support.


(grahamtrump) #3

Thanks Jay,

What should i say with google about the error? The queue too large or missing authenticate?

If I change to the another email service will solve my trouble?


(Bhanu Sharma) #4

Probably Yes! That is your only best bet for now as GSuite is really complex to get working with discourse.


(grahamtrump) #5

Please suggest for me :stuck_out_tongue:

I dont know what email service can give more budget for email sending per day.

My site may send about 5000-10000 emails/day (not include the reply/quote notifications yet)


(Bhanu Sharma) #6

You may be able to safely use mailgun. It will incur charges after the first 10k emails per month but their plans are okay!

Other good options include AWS SES but you have to be hosted on AWS for their free 62k emails to work

Another alternative is sparkpost but I’ve never used it.


(grahamtrump) #7

Thank you. I am trying with mailgun.
Another question: I have multi private emojis and I want to change the default apple emoji with my owns. How can I do it? Or at least I want to set the custom emojis to the first choice of my site.